Guest User

Untitled

a guest
Feb 14th, 2020
277
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. Microsoft Windows [Version 6.1.7601]
  2. Copyright (c) 2009 Microsoft Corporation. All rights reserved.
  3.  
  4. C:\Users\JULIE>OpenMRS-Tickets
  5. 'OpenMRS-Tickets' is not recognized as an internal or external command,
  6. operable program or batch file.
  7.  
  8. C:\Users\JULIE>cd OpenMRS-Tickets
  9.  
  10. C:\Users\JULIE\OpenMRS-Tickets>cd openmrs-ocl-client
  11.  
  12. C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client>npm install
  13. npm WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellane
  14. ous Warning ETIMEDOUT: request to https://registry.npmjs.org/node-sass-chokidar
  15. failed, reason: connect ETIMEDOUT 104.16.19.35:443
  16. npm WARN registry Using stale data from https://registry.npmjs.org/ due to a req
  17. uest error during revalidation.
  18. npm WARN deprecated request@2.88.2: request has been deprecated, see https://git
  19. hub.com/request/request/issues/3142
  20. npm WARN deprecated fsevents@1.2.4: Way too old
  21.  
  22. > node-sass@4.13.1 install C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client\nod
  23. e_modules\node-sass
  24. > node scripts/install.js
  25.  
  26. Downloading binary from https://github.com/sass/node-sass/releases/download/v4.1
  27. 3.1/win32-x64-72_binding.node
  28. Cannot download "https://github.com/sass/node-sass/releases/download/v4.13.1/win
  29. 32-x64-72_binding.node":
  30.  
  31. read ECONNRESET
  32.  
  33. Hint: If github.com is not accessible in your location
  34. try setting a proxy via HTTP_PROXY, e.g.
  35.  
  36. export HTTP_PROXY=http://example.com:1234
  37.  
  38. or configure npm proxy via
  39.  
  40. npm config set proxy http://example.com:8080
  41.  
  42. > node-sass@4.13.1 postinstall C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client
  43. \node_modules\node-sass
  44. > node scripts/build.js
  45.  
  46. Building: C:\Program Files\nodejs\node.exe C:\Users\JULIE\OpenMRS-Tickets\openmr
  47. s-ocl-client\node_modules\node-gyp\bin\node-gyp.js rebuild --verbose --libsass_e
  48. xt= --libsass_cflags= --libsass_ldflags= --libsass_library=
  49. gyp info it worked if it ends with ok
  50. gyp verb cli [
  51. gyp verb cli 'C:\\Program Files\\nodejs\\node.exe',
  52. gyp verb cli 'C:\\Users\\JULIE\\OpenMRS-Tickets\\openmrs-ocl-client\\node_modu
  53. les\\node-gyp\\bin\\node-gyp.js',
  54. gyp verb cli 'rebuild',
  55. gyp verb cli '--verbose',
  56. gyp verb cli '--libsass_ext=',
  57. gyp verb cli '--libsass_cflags=',
  58. gyp verb cli '--libsass_ldflags=',
  59. gyp verb cli '--libsass_library='
  60. gyp verb cli ]
  61. gyp info using node-gyp@3.8.0
  62. gyp info using node@12.15.0 | win32 | x64
  63. gyp verb command rebuild []
  64. gyp verb command clean []
  65. gyp verb clean removing "build" directory
  66. gyp verb command configure []
  67. gyp verb check python checking for Python executable "python2" in the PATH
  68. gyp verb `which` failed Error: not found: python2
  69. gyp verb `which` failed at getNotFoundError (C:\Users\JULIE\OpenMRS-Tickets\
  70. openmrs-ocl-client\node_modules\which\which.js:13:12)
  71. gyp verb `which` failed at F (C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-cli
  72. ent\node_modules\which\which.js:68:19)
  73. gyp verb `which` failed at E (C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-cli
  74. ent\node_modules\which\which.js:80:29)
  75. gyp verb `which` failed at C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client
  76. \node_modules\which\which.js:89:16
  77. gyp verb `which` failed at C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client
  78. \node_modules\isexe\index.js:42:5
  79. gyp verb `which` failed at C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client
  80. \node_modules\isexe\windows.js:36:5
  81. gyp verb `which` failed at FSReqCallback.oncomplete (fs.js:158:21)
  82. gyp verb `which` failed python2 Error: not found: python2
  83. gyp verb `which` failed at getNotFoundError (C:\Users\JULIE\OpenMRS-Tickets\
  84. openmrs-ocl-client\node_modules\which\which.js:13:12)
  85. gyp verb `which` failed at F (C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-cli
  86. ent\node_modules\which\which.js:68:19)
  87. gyp verb `which` failed at E (C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-cli
  88. ent\node_modules\which\which.js:80:29)
  89. gyp verb `which` failed at C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client
  90. \node_modules\which\which.js:89:16
  91. gyp verb `which` failed at C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client
  92. \node_modules\isexe\index.js:42:5
  93. gyp verb `which` failed at C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client
  94. \node_modules\isexe\windows.js:36:5
  95. gyp verb `which` failed at FSReqCallback.oncomplete (fs.js:158:21) {
  96. gyp verb `which` failed stack: 'Error: not found: python2\n' +
  97. gyp verb `which` failed ' at getNotFoundError (C:\\Users\\JULIE\\OpenMRS-
  98. Tickets\\openmrs-ocl-client\\node_modules\\which\\which.js:13:12)\n' +
  99. gyp verb `which` failed ' at F (C:\\Users\\JULIE\\OpenMRS-Tickets\\openmr
  100. s-ocl-client\\node_modules\\which\\which.js:68:19)\n' +
  101. gyp verb `which` failed ' at E (C:\\Users\\JULIE\\OpenMRS-Tickets\\openmr
  102. s-ocl-client\\node_modules\\which\\which.js:80:29)\n' +
  103. gyp verb `which` failed ' at C:\\Users\\JULIE\\OpenMRS-Tickets\\openmrs-o
  104. cl-client\\node_modules\\which\\which.js:89:16\n' +
  105. gyp verb `which` failed ' at C:\\Users\\JULIE\\OpenMRS-Tickets\\openmrs-o
  106. cl-client\\node_modules\\isexe\\index.js:42:5\n' +
  107. gyp verb `which` failed ' at C:\\Users\\JULIE\\OpenMRS-Tickets\\openmrs-o
  108. cl-client\\node_modules\\isexe\\windows.js:36:5\n' +
  109. gyp verb `which` failed ' at FSReqCallback.oncomplete (fs.js:158:21)',
  110. gyp verb `which` failed code: 'ENOENT'
  111. gyp verb `which` failed }
  112. gyp verb check python checking for Python executable "python" in the PATH
  113. gyp verb `which` succeeded python C:\Users\JULIE\AppData\Local\Programs\Python\P
  114. ython37-32\python.EXE
  115. gyp ERR! configure error
  116. gyp ERR! stack Error: Command failed: C:\Users\JULIE\AppData\Local\Programs\Pyth
  117. on\Python37-32\python.EXE -c import sys; print "%s.%s.%s" % sys.version_info[:3]
  118. ;
  119. gyp ERR! stack File "<string>", line 1
  120. gyp ERR! stack import sys; print "%s.%s.%s" % sys.version_info[:3];
  121. gyp ERR! stack ^
  122. gyp ERR! stack SyntaxError: invalid syntax
  123. gyp ERR! stack
  124. gyp ERR! stack at ChildProcess.exithandler (child_process.js:295:12)
  125. gyp ERR! stack at ChildProcess.emit (events.js:223:5)
  126. gyp ERR! stack at maybeClose (internal/child_process.js:1021:16)
  127. gyp ERR! stack at Socket.<anonymous> (internal/child_process.js:430:11)
  128. gyp ERR! stack at Socket.emit (events.js:223:5)
  129. gyp ERR! stack at Pipe.<anonymous> (net.js:664:12)
  130. gyp ERR! System Windows_NT 6.1.7601
  131. gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\JULIE\\OpenMR
  132. S-Tickets\\openmrs-ocl-client\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuil
  133. d" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libs
  134. ass_library="
  135. gyp ERR! cwd C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client\node_modules\node
  136. -sass
  137. gyp ERR! node -v v12.15.0
  138. gyp ERR! node-gyp -v v3.8.0
  139. gyp ERR! not ok
  140. Build failed with error code: 1
  141. npm WARN acorn-jsx@5.1.0 requires a peer of acorn@^6.0.0 || ^7.0.0 but none is i
  142. nstalled. You must install peer dependencies yourself.
  143. npm WARN babel-core@7.0.0-bridge.0 requires a peer of @babel/core@^7.0.0-0 but n
  144. one is installed. You must install peer dependencies yourself.
  145. npm WARN babel-plugin-named-asset-import@0.3.6 requires a peer of @babel/core@^7
  146. .1.0 but none is installed. You must install peer dependencies yourself.
  147. npm WARN bootstrap@4.4.1 requires a peer of jquery@1.9.1 - 3 but none is install
  148. ed. You must install peer dependencies yourself.
  149. npm WARN bootstrap@4.4.1 requires a peer of popper.js@^1.16.0 but none is instal
  150. led. You must install peer dependencies yourself.
  151. npm WARN eslint-config-react-app@3.0.8 requires a peer of babel-eslint@9.x but n
  152. one is installed. You must install peer dependencies yourself.
  153. npm WARN eslint-config-react-app@3.0.8 requires a peer of eslint-plugin-flowtype
  154. @2.x but none is installed. You must install peer dependencies yourself.
  155. npm WARN eslint-loader@2.1.1 requires a peer of webpack@>=2.0.0 <5.0.0 but none
  156. is installed. You must install peer dependencies yourself.
  157. npm WARN jest-pnp-resolver@1.0.2 requires a peer of jest-resolve@* but none is i
  158. nstalled. You must install peer dependencies yourself.
  159. npm WARN react-tooltip@3.11.6 requires a peer of react@>=^16.0.0 but none is ins
  160. talled. You must install peer dependencies yourself.
  161. npm WARN react-tooltip@3.11.6 requires a peer of react-dom@>=^16.0.0 but none is
  162. installed. You must install peer dependencies yourself.
  163. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.11 (node_modules\re
  164. act-scripts\node_modules\chokidar\node_modules\fsevents):
  165. npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@
  166. 1.2.11: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"
  167. })
  168. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fse
  169. vents):
  170. npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@
  171. 1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}
  172. )
  173. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.11 (node_modules\ch
  174. okidar\node_modules\fsevents):
  175. npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@
  176. 1.2.11: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"
  177. })
  178.  
  179. npm ERR! code ELIFECYCLE
  180. npm ERR! errno 1
  181. npm ERR! node-sass@4.13.1 postinstall: `node scripts/build.js`
  182. npm ERR! Exit status 1
  183. npm ERR!
  184. npm ERR! Failed at the node-sass@4.13.1 postinstall script.
  185. npm ERR! This is probably not a problem with npm. There is likely additional log
  186. ging output above.
  187.  
  188. npm ERR! A complete log of this run can be found in:
  189. npm ERR! C:\Devel\nodejs\npm-cache\_logs\2020-02-14T14_08_16_608Z-debug.log
  190.  
  191. C:\Users\JULIE\OpenMRS-Tickets\openmrs-ocl-client>
RAW Paste Data