SHARE
TWEET

lightspart build error

a guest Mar 11th, 2016 85 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. :: Synchronizing package databases...
  2.  core is up to date
  3.  extra is up to date
  4.  community is up to date
  5. :: Starting full system upgrade...
  6.  there is nothing to do
  7. Fetching origin
  8. resolving dependencies...
  9. :: There are 4 providers available for libgl:
  10. :: Repository extra
  11.    1) mesa-libgl  2) nvidia-304xx-libgl  3) nvidia-340xx-libgl  4) nvidia-libgl
  12.  
  13. Enter a number (default=1):
  14. :: There are 2 providers available for libx264.so=148-64:
  15. :: Repository extra
  16.    1) libx264  2) libx264-10bit
  17.  
  18. Enter a number (default=1):
  19. looking for conflicting packages...
  20.  
  21. Packages (128) alsa-lib-1.1.0-1  atk-2.18.0-1  avahi-0.6.32-2  cairo-1.14.6-1  compositeproto-0.4.2-3  damageproto-1.2.1-3  dbus-1.10.6-1  dcadec-0.2.0-1  elfutils-0.165-1  fixesproto-5.0-3  flac-1.3.1-3  fontconfig-2.11.1-2  freetype2-2.6.3-1  fribidi-0.19.7-1  gdk-pixbuf2-2.32.3-1  giflib-5.1.2-1  glu-9.0.0-4  graphite-1:1.3.6-1  gsm-1.0.14-1  gtk-update-icon-cache-3.18.9-1  harfbuzz-1.2.3-1  hicolor-icon-theme-0.15-1  hwids-20160306-1  icu-56.1-2  inputproto-2.3.1-1  iptables-1.4.21-3  jasper-1.900.1-14  json-c-0.12-2  kbd-2.0.3-1  kbproto-1.0.7-1  kmod-22-1  lame-3.99.5-3  libass-0.13.2-1  libasyncns-0.8-5  libbluray-0.9.2-1  libcroco-0.6.11-1  libcups-2.1.3-1  libdaemon-0.14-3  libdatrie-0.2.10-1  libdbus-1.10.6-1  libdrm-2.4.67-1  libedit-20150325_3.1-2  libelf-0.165-1  libice-1.0.9-1  libjpeg-turbo-1.4.2-2  libmikmod-3.3.8-1  libmodplug-0.8.8.5-2  libogg-1.3.2-1  libomxil-bellagio-0.9.3-1  libpciaccess-0.13.4-1  libpng-1.6.21-1  libpulse-8.0-3  librsvg-2:2.40.13-1  libseccomp-2.2.3-1  libsigc++-2.6.2-1  libsm-1.2.2-2  libsndfile-1.0.26-1  libsoxr-0.1.2-1  libssh-0.7.3-1  libthai-0.1.24-1  libtheora-1.1.1-3  libtiff-4.0.6-2  libtxc_dxtn-1.0.1-6  libusb-1.0.20-1  libva-1.6.2-1  libvdpau-1.1.1-2  libvorbis-1.3.5-1  libvpx-1.5.0-4  libwebp-0.5.0-1  libx11-1.6.3-1  libx264-2:148.20160103-1  libxau-1.0.8-2  libxcb-1.11.1-1  libxcomposite-0.4.4-2  libxcursor-1.1.14-2  libxdamage-1.1.4-2  libxdmcp-1.1.2-1  libxext-1.3.3-1  libxfixes-5.0.1-1  libxft-2.3.2-1  libxi-1.7.6-1  libxinerama-1.1.3-2  libxml2-2.9.3-1  libxmu-1.1.2-1  libxrandr-1.5.0-1  libxrender-0.9.9-1  libxshmfence-1.2-1  libxt-1.1.5-1  libxtst-1.2.2-1  libxxf86vm-1.1.4-1  llvm-libs-3.7.1-1  mesa-11.1.2-1  mesa-libgl-11.1.2-1  opencore-amr-0.1.3-2  openjpeg-1.5.2-1  opus-1.1.2-1  orc-0.4.25-1  pango-1.39.0-1  pixman-0.34.0-1  randrproto-1.5.0-1  recordproto-1.14.2-2  renderproto-0.11.1-3  schroedinger-1.0.11-3  sdl-1.2.15-7  shared-mime-info-1.5-1  smpeg-0.4.5-2  speex-1.2rc2-1  speexdsp-1.2rc3-2  sysfsutils-2.1.0-9  systemd-229-3  v4l-utils-1.10.0-1  vid.stab-1.1-1  wayland-1.10.0-1  x265-1.9-1  xcb-proto-1.11-2  xextproto-7.3.0-1  xf86vidmodeproto-2.3.1-3  xineramaproto-1.2.1-3  xproto-7.0.28-1  xvidcore-1.3.4-1  boost-libs-1.60.0-2  desktop-file-utils-0.22-1  ffmpeg-1:3.0-1  glew-1.13.0-1  glibmm-2.46.3-1  gtk2-2.24.30-1  rtmpdump-1:2.4.r96.fa8646d-2  sdl_mixer-1.2.12-4
  22.  
  23. Total Installed Size:  350.71 MiB
  24.  
  25. :: Proceed with installation? [Y/n]
  26. checking keyring...
  27. checking package integrity...
  28. loading package files...
  29. checking for file conflicts...
  30. :: Processing package changes...
  31. installing atk...
  32. installing libdatrie...
  33. installing libthai...
  34. installing libpng...
  35. installing xcb-proto...
  36. installing xproto...
  37. installing libxdmcp...
  38. installing libxau...
  39. installing libxcb...
  40. installing kbproto...
  41. installing libx11...
  42. installing renderproto...
  43. installing libxrender...
  44. installing xextproto...
  45. installing libxext...
  46. installing graphite...
  47. installing harfbuzz...
  48. Optional dependencies for harfbuzz
  49.     cairo: hb-view program [pending]
  50. installing freetype2...
  51. installing fontconfig...
  52.  
  53.   Fontconfig configuration is done via /etc/fonts/conf.avail and conf.d.
  54.   Read /etc/fonts/conf.d/README for more information.
  55.  
  56.   Configuration via /etc/fonts/local.conf is still possible,
  57.   but is no longer recommended for options available in conf.avail.
  58.  
  59.   Main systemwide configuration should be done by symlinks
  60.   (especially for autohinting, sub-pixel and lcdfilter):
  61.  
  62.   cd /etc/fonts/conf.d
  63.   ln -s ../conf.avail/XX-foo.conf
  64.  
  65.   Check also https://wiki.archlinux.org/index.php/Font_Configuration
  66.   and https://wiki.archlinux.org/index.php/Fonts.
  67.  
  68. updating font cache... done.
  69. installing pixman...
  70. installing libpciaccess...
  71. installing libdrm...
  72. installing libxml2...
  73. Optional dependencies for libxml2
  74.     python2: python bindings to libxml
  75. installing wayland...
  76. installing xf86vidmodeproto...
  77. installing libxxf86vm...
  78. installing fixesproto...
  79. installing libxfixes...
  80. installing damageproto...
  81. installing libxdamage...
  82. installing libxshmfence...
  83. installing libdbus...
  84. installing dbus...
  85. Optional dependencies for dbus
  86.     libx11: dbus-launch support [installed]
  87. installing iptables...
  88. installing kbd...
  89. installing kmod...
  90. installing hwids...
  91. installing libelf...
  92. installing libseccomp...
  93. installing systemd...
  94. Initializing machine ID from random generator.
  95. Creating group systemd-coredump with gid 999.
  96. Creating user systemd-coredump (systemd Core Dumper) with uid 999 and gid 999.
  97. Creating group systemd-journal-remote with gid 998.
  98. Creating user systemd-journal-remote (systemd Journal Remote) with uid 998 and gid 998.
  99. Creating group systemd-journal-upload with gid 997.
  100. Creating user systemd-journal-upload (systemd Journal Upload) with uid 997 and gid 997.
  101. Created symlink /etc/systemd/system/getty.target.wants/getty@tty1.service, pointing to /usr/lib/systemd/system/getty@.service.
  102. Created symlink /etc/systemd/system/multi-user.target.wants/remote-fs.target, pointing to /usr/lib/systemd/system/remote-fs.target.
  103. :: Append 'init=/usr/lib/systemd/systemd' to your kernel command line in your
  104.    bootloader to replace sysvinit with systemd, or install systemd-sysvcompat
  105. Optional dependencies for systemd
  106.     cryptsetup: required for encrypted block devices
  107.     libmicrohttpd: remote journald capabilities
  108.     quota-tools: kernel-level quota management
  109.     systemd-sysvcompat: symlink package to provide sysvinit binaries
  110.     polkit: allow administration as unprivileged user
  111. installing elfutils...
  112. installing libomxil-bellagio...
  113. installing libtxc_dxtn...
  114. installing libedit...
  115. installing llvm-libs...
  116. installing mesa...
  117. Optional dependencies for mesa
  118.     opengl-man-pages: for the OpenGL API man pages
  119.     mesa-vdpau: for accelerated video playback
  120.     libva-mesa-driver: for accelerated video playback
  121. installing mesa-libgl...
  122. installing cairo...
  123. installing libxft...
  124. installing pango...
  125. installing libxcursor...
  126. Optional dependencies for libxcursor
  127.     gnome-themes-standard: fallback icon theme
  128. installing xineramaproto...
  129. installing libxinerama...
  130. installing randrproto...
  131. installing libxrandr...
  132. installing inputproto...
  133. installing libxi...
  134. installing compositeproto...
  135. installing libxcomposite...
  136. installing shared-mime-info...
  137. installing libjpeg-turbo...
  138. installing libtiff...
  139. Optional dependencies for libtiff
  140.     freeglut: for using tiffgt
  141. installing libdaemon...
  142. installing avahi...
  143. Optional dependencies for avahi
  144.     gtk3: avahi-discover-standalone, bshell, bssh, bvnc
  145.     gtk2: gtk2 bindings [pending]
  146.     qt4: qt4 bindings
  147.     pygtk: avahi-bookmarks, avahi-discover
  148.     python2-twisted: avahi-bookmarks
  149.     mono: mono bindings
  150.     python2-dbus: avahi-discover
  151.     nss-mdns: NSS support for mDNS
  152. installing libusb...
  153. installing libcups...
  154. installing jasper...
  155. Optional dependencies for jasper
  156.     freeglut: for jiv support
  157.     glu: for jiv support [pending]
  158. installing gdk-pixbuf2...
  159. installing hicolor-icon-theme...
  160. installing gtk-update-icon-cache...
  161. installing libcroco...
  162. installing librsvg...
  163. installing gtk2...
  164. Optional dependencies for gtk2
  165.     gnome-themes-standard: Default widget theme
  166.     adwaita-icon-theme: Default icon theme
  167. installing icu...
  168. installing boost-libs...
  169. Optional dependencies for boost-libs
  170.     openmpi: for mpi support
  171. installing libice...
  172. installing libsm...
  173. installing libxt...
  174. installing libxmu...
  175. installing glu...
  176. installing glew...
  177. installing alsa-lib...
  178. Optional dependencies for alsa-lib
  179.     python2: for python smixer plugin
  180. installing fribidi...
  181. installing gsm...
  182. installing lame...
  183. installing libass...
  184. installing libbluray...
  185. Optional dependencies for libbluray
  186.     java-environment: for BD-J library
  187. installing libmodplug...
  188. installing libasyncns...
  189. installing recordproto...
  190. installing libxtst...
  191. installing libogg...
  192. installing flac...
  193. installing libvorbis...
  194. installing libsndfile...
  195. installing json-c...
  196. installing libpulse...
  197. installing libsoxr...
  198. installing libssh...
  199. installing libtheora...
  200. installing libva...
  201. Optional dependencies for libva
  202.     libva-vdpau-driver: backend for Nvidia and AMD cards
  203.     libva-intel-driver: backend for Intel cards
  204. installing libvdpau...
  205. installing giflib...
  206. installing libwebp...
  207. Optional dependencies for libwebp
  208.     freeglut: vwebp viewer
  209. installing opencore-amr...
  210. installing openjpeg...
  211. Optional dependencies for openjpeg
  212.     lcms2: j2k_to_image and image_to_j2k programs
  213.     libpng: j2k_to_image and image_to_j2k programs [installed]
  214. installing opus...
  215. installing orc...
  216. installing schroedinger...
  217. installing sdl...
  218. Optional dependencies for sdl
  219.     alsa-lib: ALSA audio driver [installed]
  220.     libpulse: PulseAudio audio driver [installed]
  221. installing speexdsp...
  222. installing speex...
  223. installing sysfsutils...
  224. installing v4l-utils...
  225. Optional dependencies for v4l-utils
  226.     qt5-base
  227.     alsa-lib [installed]
  228. installing xvidcore...
  229. installing dcadec...
  230. installing vid.stab...
  231. installing libvpx...
  232. installing libx264...
  233. installing x265...
  234. installing ffmpeg...
  235. Optional dependencies for ffmpeg
  236.     ladspa: LADSPA filters
  237. installing desktop-file-utils...
  238. installing rtmpdump...
  239. installing libmikmod...
  240. installing smpeg...
  241. Optional dependencies for smpeg
  242.     glu: to use glmovie [installed]
  243. installing sdl_mixer...
  244. Optional dependencies for sdl_mixer
  245.     fluidsynth: MIDI software synth, replaces built-in timidity
  246. installing libsigc++...
  247. installing glibmm...
  248. resolving dependencies...
  249. looking for conflicting packages...
  250.  
  251. Packages (7) jsoncpp-1.6.5-3  perl-error-0.17024-1  boost-1.60.0-2  cmake-3.4.3-1  git-2.7.2-2  llvm-3.7.1-1  nasm-2.11.08-1
  252.  
  253. Total Installed Size:  312.70 MiB
  254.  
  255. :: Proceed with installation? [Y/n]
  256. checking keyring...
  257. checking package integrity...
  258. loading package files...
  259. checking for file conflicts...
  260. :: Processing package changes...
  261. installing perl-error...
  262. installing git...
  263. Optional dependencies for git
  264.     tk: gitk and git gui
  265.     perl-libwww: git svn
  266.     perl-term-readkey: git svn
  267.     perl-mime-tools: git send-email
  268.     perl-net-smtp-ssl: git send-email TLS support
  269.     perl-authen-sasl: git send-email TLS support
  270.     python2: various helper scripts
  271.     subversion: git svn
  272.     cvsps2: git cvsimport
  273.     gnome-keyring: GNOME keyring credential helper
  274. installing jsoncpp...
  275. installing cmake...
  276. Optional dependencies for cmake
  277.     qt5-base: cmake-gui
  278.     libxkbcommon-x11: cmake-gui
  279. installing nasm...
  280. installing llvm...
  281. installing boost...
  282. Optional dependencies for boost
  283.     python: for python bindings
  284.     python2: for python2 bindings
  285.     boost-build: to use boost jam for building your project.
  286. -- The C compiler identification is GNU 5.3.0
  287. -- The CXX compiler identification is GNU 5.3.0
  288. -- Check for working C compiler: /usr/bin/cc
  289. -- Check for working C compiler: /usr/bin/cc -- works
  290. -- Detecting C compiler ABI info
  291. -- Detecting C compiler ABI info - done
  292. -- Detecting C compile features
  293. -- Detecting C compile features - done
  294. -- Check for working CXX compiler: /usr/bin/c++
  295. -- Check for working CXX compiler: /usr/bin/c++ -- works
  296. -- Detecting CXX compiler ABI info
  297. -- Detecting CXX compiler ABI info - done
  298. -- Detecting CXX compile features
  299. -- Detecting CXX compile features - done
  300. -- Performing Test GCC_IS_4_6
  301. -- Performing Test GCC_IS_4_6 - Success
  302. -- Found gnash path: /usr/bin/gtk-gnash
  303. -- The ASM-NASM compiler identification is unknown
  304. -- Found assembler: /usr/bin/nasm
  305. -- Found PkgConfig: /usr/bin/pkg-config (found version "0.29")
  306. -- LLVM llvm-config found at: /usr/bin/llvm-config
  307. -- LLVM version: 3.7.1
  308. -- Looking for C++ include llvm/Support/TargetSelect.h
  309. -- Looking for C++ include llvm/Support/TargetSelect.h - found
  310. -- HAVE_SUPPORT_TARGETSELECT_H: 1
  311. -- Looking for C++ include llvm/IRBuilder.h
  312. -- Looking for C++ include llvm/IRBuilder.h - not found
  313. -- HAVE_IRBUILDER_H:
  314. -- Looking for C++ include llvm/DataLayout.h
  315. -- Looking for C++ include llvm/DataLayout.h - not found
  316. -- Looking for C++ include llvm/IR/DataLayout.h
  317. -- Looking for C++ include llvm/IR/DataLayout.h - found
  318. -- Looking for C++ include llvm/IR/Verifier.h
  319. -- Looking for C++ include llvm/IR/Verifier.h - found
  320. -- Looking for C++ include llvm/PassManager.h
  321. -- Looking for C++ include llvm/PassManager.h - not found
  322. -- HAVE_DATALAYOUT_H:
  323. -- HAVE_IR_DATALAYOUT_H: 1
  324. -- HAVE_IR_VERIFIER_H: 1
  325. -- HAVE_PASSMANAGER_H:
  326. -- LLVM CXX flags: -I/usr/include -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong  -fPIC -fvisibility-inlines-hidden -Wall -W -Wno-unused-parameter -Wwrite-strings -Wcast-qual -Wno-missing-field-initializers -pedantic -Wno-long-long -Wno-maybe-uninitialized -Wnon-virtual-dtor -Wno-comment -std=c++11 -ffunction-sections -fdata-sections -O3 -DNDEBUG  -fno-exceptions  -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS
  327. -- LLVM LD flags: -L/usr/lib
  328. -- LLVM core libs: -lLLVMLinker-lLLVMBitWriter-lLLVMInstrumentation-lLLVMipo-lLLVMVectorize-lLLVMScalarOpts-lLLVMProfileData-lLLVMObject-lLLVMMCParser-lLLVMMC-lLLVMBitReader-lLLVMInstCombine-lLLVMTransformUtils-lLLVMipa-lLLVMAnalysis-lLLVMCore-lLLVMSupport-lrt -ldl -lcurses -lpthread -lz -lm
  329. -- LLVM JIT libs: -lLLVMX86Disassembler-lLLVMX86AsmParser-lLLVMX86CodeGen-lLLVMSelectionDAG-lLLVMAsmPrinter-lLLVMCodeGen-lLLVMScalarOpts-lLLVMProfileData-lLLVMInstCombine-lLLVMInstrumentation-lLLVMTransformUtils-lLLVMipa-lLLVMX86Desc-lLLVMMCDisassembler-lLLVMX86Info-lLLVMX86AsmPrinter-lLLVMX86Utils-lLLVMMCJIT-lLLVMExecutionEngine-lLLVMTarget-lLLVMAnalysis-lLLVMRuntimeDyld-lLLVMObject-lLLVMMCParser-lLLVMBitReader-lLLVMMC-lLLVMCore-lLLVMSupport
  330. -- LLVM JIT objs:
  331. -- Found LLVM: /usr/include
  332. -- Found ZLIB: /usr/lib64/libz.so (found version "1.2.8")
  333. -- Found Freetype: /usr/lib64/libfreetype.so  
  334. -- Found OpenGL: /usr/lib64/libGL.so  
  335. -- Found GLEW: /usr/lib64/libGLEW.so  
  336. -- Found PCRE: /usr/lib64/libpcre.so  
  337. -- Found JPEG: /usr/lib64/libjpeg.so  
  338. -- Found PNG: /usr/lib64/libpng.so (found version "1.6.21")
  339. -- Checking for module 'liblzma'
  340. --   Found liblzma, version 5.2.2
  341. -- Boost version: 1.60.0
  342. -- Found the following Boost libraries:
  343. --   filesystem
  344. --   system
  345. -- Checking for modules 'cairo;pangocairo'
  346. --   Found cairo, version 1.14.6
  347. --   Found pangocairo, version 1.39.0
  348. -- Checking for module 'x11'
  349. --   Found x11, version 1.6.3
  350. -- Checking for modules 'libavcodec;libavutil;libavformat'
  351. --   Found libavcodec, version 57.24.102
  352. --   Found libavutil, version 55.17.103
  353. --   Found libavformat, version 57.25.100
  354. -- Checking for module 'libavresample'
  355. --   Found libavresample, version 3.0.0
  356. -- Looking for avcodec_decode_video2
  357. -- Looking for avcodec_decode_video2 - found
  358. -- Looking for avcodec_decode_audio3
  359. -- Looking for avcodec_decode_audio3 - not found
  360. -- Looking for avcodec_decode_audio4
  361. -- Looking for avcodec_decode_audio4 - found
  362. -- Looking for avio_alloc_context
  363. -- Looking for avio_alloc_context - found
  364. -- Looking for avcodec_alloc_context3
  365. -- Looking for avcodec_alloc_context3 - found
  366. -- Looking for avcodec_open2
  367. -- Looking for avcodec_open2 - found
  368. -- Looking for avformat_close_input
  369. -- Looking for avformat_close_input - found
  370. -- Looking for avformat_find_stream_info
  371. -- Looking for avformat_find_stream_info - found
  372. -- Looking for av_frame_alloc
  373. -- Looking for av_frame_alloc - found
  374. -- Looking for av_frame_unref
  375. -- Looking for av_frame_unref - found
  376. -- Performing Test HAVE_AVCODECID
  377. -- Performing Test HAVE_AVCODECID - Success
  378. -- Checking for module 'glib-2.0'
  379. --   Found glib-2.0, version 2.46.2
  380. -- Checking for module 'gthread-2.0'
  381. --   Found gthread-2.0, version 2.46.2
  382. -- Checking for module 'gmodule-2.0'
  383. --   Found gmodule-2.0, version 2.46.2
  384. -- Checking for module 'glibmm-2.4'
  385. --   Found glibmm-2.4, version 2.46.3
  386. -- Checking for module 'gtk+-2.0'
  387. --   Found gtk+-2.0, version 2.24.30
  388. -- Checking for module 'libcurl'
  389. --   Found libcurl, version 7.47.1
  390. -- Checking for module 'librtmp'
  391. --   Found librtmp, version v2.4
  392. -- Looking for C++ include atomic
  393. -- Looking for C++ include atomic - found
  394. -- Checking for module 'libpulse'
  395. --   Found libpulse, version 8.0
  396. -- Checking for module 'sdl'
  397. --   Found sdl, version 1.2.15
  398. -- Checking for modules ''
  399. Must specify package names on the command line
  400. Must specify package names on the command line
  401. Must specify package names on the command line
  402. Must specify package names on the command line
  403. Must specify package names on the command line
  404. Must specify package names on the command line
  405. Must specify package names on the command line
  406. Must specify package names on the command line
  407. Must specify package names on the command line
  408. Must specify package names on the command line
  409. Must specify package names on the command line
  410. Must specify package names on the command line
  411. Must specify package names on the command line
  412. Must specify package names on the command line
  413. -- Configuring done
  414. CMake Warning (dev) in src/CMakeLists.txt:
  415.   Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  416.   interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  417.   cmake_policy command to set the policy and suppress this warning.
  418.  
  419.   Target "spark" has an INTERFACE_LINK_LIBRARIES property which differs from
  420.   its LINK_INTERFACE_LIBRARIES properties.
  421.  
  422.   INTERFACE_LINK_LIBRARIES:
  423.  
  424.     pangocairo-1.0;pango-1.0;gobject-2.0;glib-2.0;cairo;/usr/lib64/libz.so;/usr/lib64/libboost_filesystem.so;/usr/lib64/libboost_system.so;-lLLVMLinker;-lLLVMBitWriter;-lLLVMInstrumentation;-lLLVMipo;-lLLVMVectorize;-lLLVMScalarOpts;-lLLVMProfileData;-lLLVMObject;-lLLVMMCParser;-lLLVMMC;-lLLVMBitReader;-lLLVMInstCombine;-lLLVMTransformUtils;-lLLVMipa;-lLLVMAnalysis;-lLLVMCore;-lLLVMSupport;-lrt -ldl -lcurses -lpthread -lz -lm;-lLLVMX86Disassembler;-lLLVMX86AsmParser;-lLLVMX86CodeGen;-lLLVMSelectionDAG;-lLLVMAsmPrinter;-lLLVMCodeGen;-lLLVMScalarOpts;-lLLVMProfileData;-lLLVMInstCombine;-lLLVMInstrumentation;-lLLVMTransformUtils;-lLLVMipa;-lLLVMX86Desc;-lLLVMMCDisassembler;-lLLVMX86Info;-lLLVMX86AsmPrinter;-lLLVMX86Utils;-lLLVMMCJIT;-lLLVMExecutionEngine;-lLLVMTarget;-lLLVMAnalysis;-lLLVMRuntimeDyld;-lLLVMObject;-lLLVMMCParser;-lLLVMBitReader;-lLLVMMC;-lLLVMCore;-lLLVMSupport;-L/usr/lib;lzma;avcodec;avutil;avformat;avresample;curl;rtmp;z;ssl;crypto;gtk-x11-2.0;gdk-x11-2.0;pangocairo-1.0;atk-1.0;cairo;gdk_pixbuf-2.0;gio-2.0;pangoft2-1.0;pango-1.0;gobject-2.0;glib-2.0;fontconfig;freetype;/usr/lib64/libfreetype.so;/usr/lib64/libjpeg.so;/usr/lib64/libpng.so;/usr/lib64/libz.so;/usr/lib64/libpcre.so;glibmm-2.4;gobject-2.0;glib-2.0;sigc-2.0;gmodule-2.0;glib-2.0;dl;X11;/usr/lib64/libGLU.so;/usr/lib64/libGL.so;/usr/lib64/libGLEW.so
  425.  
  426.   LINK_INTERFACE_LIBRARIES:
  427.  
  428.    
  429.  
  430. This warning is for project developers.  Use -Wno-dev to suppress it.
  431.  
  432. -- Generating done
  433. -- Build files have been written to: /build/lightspark-git/src/lightspark
  434. Scanning dependencies of target translations
  435. [  1%] Generating pl.gmo
  436. [  2%] Generating fr.gmo
  437. [  3%] Generating zh_CN.gmo
  438. [  3%] Built target translations
  439. Scanning dependencies of target spark
  440. [  4%] Building CXX object src/CMakeFiles/spark.dir/allclasses.cpp.o
  441. [  4%] Building CXX object src/CMakeFiles/spark.dir/asobject.cpp.o
  442. [  5%] Building CXX object src/CMakeFiles/spark.dir/compat.cpp.o
  443. [  6%] Building CXX object src/CMakeFiles/spark.dir/logger.cpp.o
  444. [  6%] Building CXX object src/CMakeFiles/spark.dir/memory_support.cpp.o
  445. [  7%] Building CXX object src/CMakeFiles/spark.dir/swf.cpp.o
  446. In file included from /build/lightspark-git/src/lightspark/src/scripting/flash/display/flashdisplay.h:32:0,
  447.                  from /build/lightspark-git/src/lightspark/src/swf.h:31,
  448.                  from /build/lightspark-git/src/lightspark/src/scripting/class.h:28,
  449.                  from /build/lightspark-git/src/lightspark/src/parsing/tags.h:29,
  450.                  from /build/lightspark-git/src/lightspark/src/scripting/abc.h:25,
  451.                  from /build/lightspark-git/src/lightspark/src/swf.cpp:23:
  452. /build/lightspark-git/src/lightspark/src/scripting/class.h: In instantiation of 'static T* lightspark::Class<T>::getInstanceS(Args&& ...) [with Args = {}; T = lightspark::Stage]':
  453. /build/lightspark-git/src/lightspark/src/swf.cpp:253:35:   required from here
  454. /build/lightspark-git/src/lightspark/src/scripting/flash/display/DisplayObject.h:120:7: error: 'virtual void lightspark::DisplayObject::constructionComplete()' is protected
  455.   void constructionComplete();
  456.        ^
  457. In file included from /build/lightspark-git/src/lightspark/src/parsing/tags.h:29:0,
  458.                  from /build/lightspark-git/src/lightspark/src/scripting/abc.h:25,
  459.                  from /build/lightspark-git/src/lightspark/src/swf.cpp:23:
  460. /build/lightspark-git/src/lightspark/src/scripting/class.h:148:3: error: within this context
  461.    ret->constructionComplete();
  462.    ^
  463. In file included from /build/lightspark-git/src/lightspark/src/scripting/flash/display/flashdisplay.h:32:0,
  464.                  from /build/lightspark-git/src/lightspark/src/swf.h:31,
  465.                  from /build/lightspark-git/src/lightspark/src/scripting/class.h:28,
  466.                  from /build/lightspark-git/src/lightspark/src/parsing/tags.h:29,
  467.                  from /build/lightspark-git/src/lightspark/src/scripting/abc.h:25,
  468.                  from /build/lightspark-git/src/lightspark/src/swf.cpp:23:
  469. /build/lightspark-git/src/lightspark/src/scripting/class.h: In instantiation of 'static T* lightspark::Class<T>::getInstanceS(Args&& ...) [with Args = {lightspark::NullableRef<lightspark::LoaderInfo>&, std::basic_istream<char, std::char_traits<char> >*, lightspark::FILE_TYPE&}; T = lightspark::Bitmap]':
  470. /build/lightspark-git/src/lightspark/src/swf.cpp:1526:67:   required from here
  471. /build/lightspark-git/src/lightspark/src/scripting/flash/display/DisplayObject.h:120:7: error: 'virtual void lightspark::DisplayObject::constructionComplete()' is protected
  472.   void constructionComplete();
  473.        ^
  474. In file included from /build/lightspark-git/src/lightspark/src/parsing/tags.h:29:0,
  475.                  from /build/lightspark-git/src/lightspark/src/scripting/abc.h:25,
  476.                  from /build/lightspark-git/src/lightspark/src/swf.cpp:23:
  477. /build/lightspark-git/src/lightspark/src/scripting/class.h:148:3: error: within this context
  478.    ret->constructionComplete();
  479.    ^
  480. src/CMakeFiles/spark.dir/build.make:182: recipe for target 'src/CMakeFiles/spark.dir/swf.cpp.o' failed
  481. make[2]: *** [src/CMakeFiles/spark.dir/swf.cpp.o] Error 1
  482. CMakeFiles/Makefile2:168: recipe for target 'src/CMakeFiles/spark.dir/all' failed
  483. make[1]: *** [src/CMakeFiles/spark.dir/all] Error 2
  484. Makefile:149: recipe for target 'all' failed
  485. make: *** [all] Error 2
  486. ==> ERROR:(B A failure occurred in build().(B
  487.     Aborting...(B
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top