PastePo

Rocky Linux migration fail

Jun 23rd, 2021
1,184
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. # installed centos SIG repository ansible, glusterfs
  2. #  dnf -y install centos-release-gluster9 centos-release-ansible-29
  3. #  dnf -y install glusterfs-server glusterfs glusterfs-fuse ansible
  4.  
  5. login as: root
  6. root@172.25.21.235's password:
  7. Last login: Wed Jun 23 14:59:55 2021
  8.  
  9. [root@centos migrate2rocky]# ./migrate2rocky.sh  -r
  10. Preparing to migrate CentOS Linux 8 to Rocky Linux 8.
  11.  
  12. Determining repository names for CentOS Linux 8.....
  13.  
  14. Found the following repositories which map from CentOS Linux 8 to Rocky Linux 8:
  15. CentOS Linux 8  Rocky Linux 8
  16. appstream       appstream
  17. baseos          baseos
  18. extras          extras
  19.  
  20. Getting system package names for CentOS Linux 8........
  21.  
  22. Found the following system packages which map from CentOS Linux 8 to Rocky Linux 8:
  23. CentOS Linux 8        Rocky Linux 8
  24. centos-backgrounds    rocky-backgrounds
  25. centos-gpg-keys       rocky-gpg-keys
  26. centos-logos          rocky-logos
  27. centos-indexhtml      rocky-indexhtml
  28. centos-linux-release  rocky-release
  29. centos-linux-repos    rocky-repos
  30.  
  31. Getting list of installed system packages.
  32.  
  33. We will replace the following CentOS Linux 8 packages with their Rocky Linux 8 equival
  34. Packages to be Removed  Packages to be Installed
  35. centos-gpg-keys         rocky-gpg-keys
  36. centos-linux-release    rocky-release
  37. centos-linux-repos      rocky-repos
  38.  
  39. In addition to the above the following system packages will be removed:
  40. centos-linux-release
  41. centos-linux-release
  42.  
  43. Getting a list of enabled modules for the system repositories.
  44.  
  45. Excluding modules:
  46. libselinux-python:2.8
  47.  
  48. Found the following modules to re-enable at completion:
  49. perl:5.26
  50. perl-IO-Socket-SSL:2.066
  51. perl-libwww-perl:6.34
  52. python36:3.6
  53.  
  54. Added rockyappstream repo from https://dl.rockylinux.org/pub/rocky/8/AppStream/x86_64/
  55. Added rockybaseos repo from https://dl.rockylinux.org/pub/rocky/8/BaseOS/x86_64/os/
  56. rockyappstream                                  4.2 MB/s | 7.1 MB     00:01
  57. rockybaseos                                     3.4 MB/s | 2.5 MB     00:00
  58. > > > ================================================================================
  59. Package                         Arch     Version           Repository     Size
  60. ================================================================================
  61. Installing:
  62. rocky-gpg-keys                  noarch   8.4-26.el8        rockybaseos    11 k
  63. rocky-release                   noarch   8.4-26.el8        rockybaseos    19 k
  64. rocky-repos                     noarch   8.4-26.el8        rockybaseos    12 k
  65. Removing:
  66. centos-gpg-keys                 noarch   1:8-2.el8         @baseos       3.3 k
  67. centos-linux-release            noarch   8.4-1.2105.el8    @baseos        25 k
  68. centos-linux-repos              noarch   8-2.el8           @baseos        26 k
  69. Removing dependent packages:
  70. centos-release-gluster9         noarch   1.0-1.el8         @extras       1.1 k
  71. centos-release-storage-common   noarch   2-2.el8           @extras       1.4 k
  72.  
  73. Transaction Summary
  74. ================================================================================
  75. Install  3 Packages
  76. Remove   5 Packages
  77.  
  78. Total download size: 43 k
  79. Downloading Packages:
  80. (1/3): rocky-gpg-keys-8.4-26.el8.noarch.rpm     136 kB/s |  11 kB     00:00
  81. (2/3): rocky-release-8.4-26.el8.noarch.rpm      205 kB/s |  19 kB     00:00
  82. (3/3): rocky-repos-8.4-26.el8.noarch.rpm        128 kB/s |  12 kB     00:00
  83. --------------------------------------------------------------------------------
  84. Total                                           424 kB/s |  43 kB     00:00
  85. rockybaseos                                     1.6 MB/s | 1.6 kB     00:00
  86. warning: /var/cache/dnf/rockybaseos-56e41edc159a87c2/packages/rocky-gpg-keys-8.4-26.el
  87. Importing GPG key 0x6D745A60:
  88. Userid     : "Release Engineering <infrastructure@rockylinux.org>"
  89. Fingerprint: 7051 C470 A929 F454 CEBE 37B7 15AF 5DAC 6D74 5A60
  90. From       : /tmp/tmp.0liqJgS0xB/gpg/RPM-GPG-KEY-rockyofficial
  91. Key imported successfully
  92. Running transaction check
  93. Transaction check succeeded.
  94. Running transaction test
  95. Transaction test succeeded.
  96. Running transaction
  97.  Preparing        :                                                        1/1
  98.  Running scriptlet: rocky-gpg-keys-8.4-26.el8.noarch                       1/1
  99.  Installing       : rocky-gpg-keys-8.4-26.el8.noarch                       1/8
  100.  Installing       : rocky-release-8.4-26.el8.noarch                        2/8
  101.  Installing       : rocky-repos-8.4-26.el8.noarch                          3/8
  102.  Running scriptlet: centos-release-gluster9-1.0-1.el8.noarch               4/8
  103.  Erasing          : centos-release-gluster9-1.0-1.el8.noarch               4/8
  104.  Running scriptlet: centos-release-gluster9-1.0-1.el8.noarch               4/8
  105.  Erasing          : centos-release-storage-common-2-2.el8.noarch           5/8
  106.  Erasing          : centos-linux-release-8.4-1.2105.el8.noarch             6/8
  107.  Erasing          : centos-linux-repos-8-2.el8.noarch                      7/8
  108.  Erasing          : centos-gpg-keys-1:8-2.el8.noarch                       8/8
  109.  Running scriptlet: centos-gpg-keys-1:8-2.el8.noarch                       8/8
  110.  Verifying        : rocky-gpg-keys-8.4-26.el8.noarch                       1/8
  111.  Verifying        : rocky-release-8.4-26.el8.noarch                        2/8
  112.  Verifying        : rocky-repos-8.4-26.el8.noarch                          3/8
  113.  Verifying        : centos-gpg-keys-1:8-2.el8.noarch                       4/8
  114.  Verifying        : centos-linux-release-8.4-1.2105.el8.noarch             5/8
  115.  Verifying        : centos-linux-repos-8-2.el8.noarch                      6/8
  116.  Verifying        : centos-release-gluster9-1.0-1.el8.noarch               7/8
  117.  Verifying        : centos-release-storage-common-2-2.el8.noarch           8/8
  118.  
  119. Installed:
  120.  rocky-gpg-keys-8.4-26.el8.noarch        rocky-release-8.4-26.el8.noarch
  121.  rocky-repos-8.4-26.el8.noarch
  122. Removed:
  123.  centos-gpg-keys-1:8-2.el8.noarch
  124.  centos-linux-release-8.4-1.2105.el8.noarch
  125.  centos-linux-repos-8-2.el8.noarch
  126.  centos-release-gluster9-1.0-1.el8.noarch
  127.  centos-release-storage-common-2-2.el8.noarch
  128.  
  129. Complete!
  130. Last metadata expiration check: 0:00:03 ago on Wed 23 Jun 2021 03:01:27 PM KST.
  131. > Leaving Shell
  132.  
  133. Removing dnf cache
  134. Ensuring repos are enabled before the package swap
  135. Enabling modules
  136.  
  137. CentOS Configmanagement SIG - ansible-29        2.1 MB/s | 1.7 MB     00:00
  138. Rocky Linux 8 - AppStream                        10 MB/s | 7.1 MB     00:00
  139. Rocky Linux 8 - BaseOS                          6.3 MB/s | 2.5 MB     00:00
  140. Rocky Linux 8 - Extras                          9.6 kB/s | 2.7 kB     00:00
  141. Extra Packages for Enterprise Linux Modular 8 - 1.2 MB/s | 611 kB     00:00
  142. Extra Packages for Enterprise Linux 8 - x86_64  120 kB/s | 9.5 MB     01:21
  143. Dependencies resolved.
  144. Nothing to do.
  145. Complete!
  146. Disabling excluded modules
  147.  
  148. Last metadata expiration check: 0:01:20 ago on Wed 23 Jun 2021 03:01:43 PM KST.
  149. Only module name is required. Ignoring unneeded information in argument: 'libselinux-p
  150. Dependencies resolved.
  151. ================================================================================
  152.  Package           Architecture     Version             Repository         Size
  153. ================================================================================
  154. Disabling modules:
  155.  libselinux-python
  156.  
  157. Transaction Summary
  158. ================================================================================
  159.  
  160. Complete!
  161.  
  162. Syncing packages
  163.  
  164. Last metadata expiration check: 0:01:21 ago on Wed 23 Jun 2021 03:01:43 PM KST.
  165. Error:
  166.  Problem 1: package glusterfs-server-9.2-1.el8.x86_64 requires glusterfs = 9.2-1.el8,
  167.   - glusterfs-9.2-1.el8.x86_64 does not belong to a distupgrade repository
  168.   - problem with installed package glusterfs-server-9.2-1.el8.x86_64
  169.  Problem 2: package libgfapi0-9.2-1.el8.x86_64 requires glusterfs-client-xlators(x86-6
  170.   - glusterfs-client-xlators-9.2-1.el8.x86_64 does not belong to a distupgrade reposit
  171.   - problem with installed package libgfapi0-9.2-1.el8.x86_64
  172.  Problem 3: package glusterfs-6.0-49.1.el8.x86_64 requires glusterfs-libs(x86-64) = 6.
  173.   - installed package libgfchangelog0-9.2-1.el8.x86_64 obsoletes glusterfs-libs <= 9.2
  174.   - cannot install the best update candidate for package glusterfs-9.2-1.el8.x86_64
  175.   - problem with installed package libgfchangelog0-9.2-1.el8.x86_64
  176.  Problem 4: package glusterfs-cli-6.0-49.1.el8.x86_64 requires glusterfs-libs(x86-64)
  177.   - installed package libgfrpc0-9.2-1.el8.x86_64 obsoletes glusterfs-libs <= 9.2-1.el8
  178.   - cannot install the best update candidate for package glusterfs-cli-9.2-1.el8.x86_6
  179.   - problem with installed package libgfrpc0-9.2-1.el8.x86_64
  180.  Problem 5: package glusterfs-client-xlators-6.0-49.1.el8.x86_64 requires glusterfs-li
  181.   - installed package libgfxdr0-9.2-1.el8.x86_64 obsoletes glusterfs-libs <= 9.2-1.el8
  182.   - cannot install the best update candidate for package glusterfs-client-xlators-9.2-
  183.   - problem with installed package libgfxdr0-9.2-1.el8.x86_64
  184.  Problem 6: package glusterfs-fuse-6.0-49.1.el8.x86_64 requires glusterfs-libs(x86-64)
  185.   - installed package libglusterd0-9.2-1.el8.x86_64 obsoletes glusterfs-libs <= 9.2-1.
  186.   - cannot install the best update candidate for package glusterfs-fuse-9.2-1.el8.x86_
  187.   - problem with installed package libglusterd0-9.2-1.el8.x86_64
  188.  Problem 7: package glusterfs-fuse-6.0-49.1.el8.x86_64 requires glusterfs-libs(x86-64)
  189.   - problem with installed package glusterfs-fuse-9.2-1.el8.x86_64
  190.   - installed package libglusterfs0-9.2-1.el8.x86_64 obsoletes glusterfs-libs <= 9.2-1
  191.   - glusterfs-fuse-9.2-1.el8.x86_64 does not belong to a distupgrade repository
  192.   - problem with installed package libglusterfs0-9.2-1.el8.x86_64
  193. (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not on
  194.  
  195. Error during distro-sync.
  196.  
  197. An error occurred while we were attempting to convert your system to Rocky Linux. Your
  198.  
  199.  A log of this installation can be found at /var/log/migrate2rocky.log
  200. [root@centos migrate2rocky]#
  201.  
RAW Paste Data