Guest User

Untitled

a guest
Nov 14th, 2019
127
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. Функция СведенияОВнешнейОбработке() Экспорт
  2. ПараметрыРегистрации = Новый Структура;
  3. МассивНазначений = Новый Массив;
  4. МассивНазначений.Добавить("Документ.ПеремещениеТоваров"); //Указываем документ к которому делаем внешнюю печ. форму
  5. ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
  6. ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
  7. ПараметрыРегистрации.Вставить("Наименование", "Печать ТОРГ-13 с массой"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
  8. ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
  9. ПараметрыРегистрации.Вставить("Версия", "1.0");
  10. ПараметрыРегистрации.Вставить("Информация", "Печать ТОРГ-13 с массой в документе Перемещения товаров");
  11. ТаблицаКоманд = ПолучитьТаблицуКоманд();
  12. ДобавитьКоманду(ТаблицаКоманд, "Печать ТОРГ-13 с массой", "ТОРГ13СМассойВнешняя", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
  13. ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
  14. Возврат ПараметрыРегистрации;
  15. КонецФункции
  16.  
  17. Функция ПолучитьТаблицуКоманд()
  18. Команды = Новый ТаблицаЗначений;
  19. Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
  20. Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
  21. Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
  22. Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  23. Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  24. Возврат Команды;
  25. КонецФункции
  26.  
  27. Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
  28.  
  29. НоваяКоманда = ТаблицаКоманд.Добавить();
  30. НоваяКоманда.Представление = Представление;
  31. НоваяКоманда.Идентификатор = Идентификатор;
  32. НоваяКоманда.Использование = Использование;
  33. НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  34. НоваяКоманда.Модификатор = Модификатор;
  35.  
  36. КонецПроцедуры
RAW Paste Data