SHARE
TWEET

Untitled

a guest Feb 17th, 2017 70 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. JennifersiMac2:~ mattpritchard$ gem install mechanize
  2. Building native extensions.  This could take a while...
  3. ERROR:  Error installing mechanize:
  4.     ERROR: Failed to build gem native extension.
  5.  
  6.     current directory: /Users/mattpritchard/.rvm/gems/ruby-2.4.0/gems/nokogiri-1.7.0.1/ext/nokogiri
  7. /Users/mattpritchard/.rvm/rubies/ruby-2.4.0/bin/ruby -r ./siteconf20170217-65267-riosnw.rb extconf.rb
  8. checking if the C compiler accepts ... yes
  9. checking if the C compiler accepts -Wno-error=unused-command-line-argument-hard-error-in-future... no
  10. Building nokogiri using packaged libraries.
  11. *** extconf.rb failed ***
  12. Could not create Makefile due to some reason, probably lack of necessary
  13. libraries and/or headers.  Check the mkmf.log file for more details.  You may
  14. need configuration options.
  15.  
  16. Provided configuration options:
  17.     --with-opt-dir
  18.     --with-opt-include
  19.     --without-opt-include=${opt-dir}/include
  20.     --with-opt-lib
  21.     --without-opt-lib=${opt-dir}/lib
  22.     --with-make-prog
  23.     --without-make-prog
  24.     --srcdir=.
  25.     --curdir
  26.     --ruby=/Users/mattpritchard/.rvm/rubies/ruby-2.4.0/bin/$(RUBY_BASE_NAME)
  27.     --help
  28.     --clean
  29.     --use-system-libraries
  30. /Users/mattpritchard/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- openssl (LoadError)
  31.     from /Users/mattpritchard/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
  32.     from /Users/mattpritchard/.rvm/rubies/ruby-2.4.0/lib/ruby/2.4.0/net/https.rb:23:in `<top (required)>'
  33.     from /Users/mattpritchard/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
  34.     from /Users/mattpritchard/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
  35.     from /Users/mattpritchard/.rvm/gems/ruby-2.4.0/gems/mini_portile2-2.1.0/lib/mini_portile2/mini_portile.rb:3:in `<top (required)>'
  36.     from /Users/mattpritchard/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
  37.     from /Users/mattpritchard/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
  38.     from /Users/mattpritchard/.rvm/gems/ruby-2.4.0/gems/mini_portile2-2.1.0/lib/mini_portile2.rb:2:in `<top (required)>'
  39.     from /Users/mattpritchard/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
  40.     from /Users/mattpritchard/.rvm/rubies/ruby-2.4.0/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
  41.     from extconf.rb:460:in `<main>'
  42.  
  43. To see why this extension failed to compile, please check the mkmf.log which can be found here:
  44.  
  45.   /Users/mattpritchard/.rvm/gems/ruby-2.4.0/extensions/x86_64-darwin-16/2.4.0/nokogiri-1.7.0.1/mkmf.log
  46.  
  47. extconf failed, exit code 1
  48.  
  49. Gem files will remain installed in /Users/mattpritchard/.rvm/gems/ruby-2.4.0/gems/nokogiri-1.7.0.1 for inspection.
  50. Results logged to /Users/mattpritchard/.rvm/gems/ruby-2.4.0/extensions/x86_64-darwin-16/2.4.0/nokogiri-1.7.0.1/gem_make.out
RAW Paste Data
Top