Want more features on Pastebin? Sign Up, it's FREE!
Guest

Untitled

By: a guest on Oct 21st, 2010  |  syntax: XPP  |  size: 18.51 KB  |  views: 164  |  expires: Never
download  |  raw  |  embed  |  report abuse  |  print
Text below is selected. Please press Ctrl+C to copy to your clipboard. (⌘+C on Mac)
  1.  
  2.  
  3. Comment by: a1russell on Fri, 08 Oct 2010 00:46:11 +0000
  4. Someone had flagged the samba4 package out of date. If someone wants the latest samba4 for some reason or another, I don't want to deny it to them. I'd be more apt to improve the samba4 PKGBUILD to work with anything else that would depend on it than to keep it coupled with openchange. Do you think this is wrong?     
  5.  
  6. Comment by: ngoonee on Sun, 17 Oct 2010 22:52:30 +0000
  7. Considering samba4 is alpha software (and the only desktop-facing reason I can think of for using it is for evo-mapi, see ubuntu repos for example) I wouldn't expect any other software to depend on it, nor people to use it directly. If that's the case though, then this package should depend on samba4-openchange.      
  8.  
  9. Comment by: kiwisauce on Tue, 19 Oct 2010 09:16:26 +0000
  10. It does not compile:
  11.  
  12.  
  13.  
  14. libmapi/mapidump.c: In function ‘mapidump_Recipients’:
  15.  
  16. libmapi/mapidump.c:216:3: warning: case value ‘0’ not in enumerated type ‘enum MAPITAGS’
  17.  
  18. libmapi/mapidump.c:219:3: warning: case value ‘1’ not in enumerated type ‘enum MAPITAGS’
  19.  
  20. libmapi/mapidump.c:222:3: warning: case value ‘2’ not in enumerated type ‘enum MAPITAGS’
  21.  
  22. Compiling libmapi/mapicode.c with -fPIC
  23.  
  24. Compiling libmapi/codepage_lcid.c with -fPIC
  25.  
  26. Compiling libmapi/mapi_nameid.c with -fPIC
  27.  
  28. Compiling libmapi/nspi.c with -fPIC
  29.  
  30. Compiling libmapi/simple_mapi.c with -fPIC
  31.  
  32. Compiling libmapi/freebusy.c with -fPIC
  33.  
  34. Compiling libmapi/x500.c with -fPIC
  35.  
  36. Compiling ndr_mapi.c with -fPIC
  37.  
  38. Compiling gen_ndr/ndr_exchange.c with -fPIC
  39.  
  40. Compiling gen_ndr/ndr_exchange_c.c with -fPIC
  41.  
  42. Compiling gen_ndr/ndr_property.c with -fPIC
  43.  
  44. Compiling libmapi/socket/interface.c with -fPIC
  45.  
  46. Compiling libmapi/socket/netif.c with -fPIC
  47.  
  48. Linking libmapi.so.0.10
  49.  
  50. /usr/bin/ld: cannot find -lldb
  51.  
  52. collect2: ld returned 1 exit status
  53.  
  54. make: *** [libmapi.so.0.10] Error 1
  55.  
  56. Aborting...
  57.  
  58. == ERROR: Makepkg was unable to build openchange.
  59.  
  60. == Restart building openchange ? [y/N]
  61.  
  62. == -----------------------------------
  63.  
  64. ==
  65.  
  66.  
  67. Comment by: a1russell on Wed, 20 Oct 2010 07:14:39 +0000
  68. @kiwisauce Try it now and let me know if you have any problems. You'll have to upgrade samba4, as well.
  69.  
  70. Comment by: kiwisauce on Thu, 21 Oct 2010 10:26:17 +0000
  71. I already have the same problem :(     
  72.  
  73. Comment by: a1russell on Thu, 21 Oct 2010 14:21:50 +0000
  74. @kiwisauce: I'm not sure what could be wrong. If you figure it out and have some improvements to make to the PKGBUILD, let me know. If you want, put in a pastebin the whole log for trying to install openchange and email it to me. Also include the output of ls -l /opt/samba4/lib/ .      
  75.  
  76. First Submitted: Fri, 20 Aug 2010 16:19:47 +0000       
  77. openchange 0.10-2 : Library for MAPI connectivity with Microsoft Exchange. This package was SPECIFICALLY created to support evolution-mapi and may not work for any other purpose.
  78. ( Unsupported package: Potentially dangerous ! )
  79.  - samba4=4.0.0A13 (already installed)
  80.  - popt (already installed)
  81.  - libical (already installed)
  82.  - sqlite3 (already installed)
  83.  - file (already installed)
  84.  - boost (already installed)
  85.  - zlib (already installed)
  86.  - ccache (already installed)
  87.  - python2 (already installed)
  88.  - subversion (already installed)
  89.  - git (already installed)
  90.  - docbook-xsl (already installed)
  91.  - libxslt (already installed)
  92.  
  93.  
  94.  
  95. ./autogen.sh: running aclocal
  96. configure.ac:404: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
  97. ../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
  98. ../../lib/autoconf/general.m4:2591: _AC_COMPILE_IFELSE is expanded from...
  99. ../../lib/autoconf/general.m4:2607: AC_COMPILE_IFELSE is expanded from...
  100. ../../lib/m4sugar/m4sh.m4:606: AS_IF is expanded from...
  101. ../../lib/autoconf/general.m4:2032: AC_CACHE_VAL is expanded from...
  102. ../../lib/autoconf/general.m4:2053: AC_CACHE_CHECK is expanded from...
  103. configure.ac:404: the top level
  104. ./autogen.sh: running autoheader
  105. configure.ac:404: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
  106. ../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
  107. ../../lib/autoconf/general.m4:2591: _AC_COMPILE_IFELSE is expanded from...
  108. ../../lib/autoconf/general.m4:2607: AC_COMPILE_IFELSE is expanded from...
  109. ../../lib/m4sugar/m4sh.m4:606: AS_IF is expanded from...
  110. ../../lib/autoconf/general.m4:2032: AC_CACHE_VAL is expanded from...
  111. ../../lib/autoconf/general.m4:2053: AC_CACHE_CHECK is expanded from...
  112. configure.ac:404: the top level
  113. ./autogen.sh: running autoconf
  114. configure.ac:404: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
  115. ../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
  116. ../../lib/autoconf/general.m4:2591: _AC_COMPILE_IFELSE is expanded from...
  117. ../../lib/autoconf/general.m4:2607: AC_COMPILE_IFELSE is expanded from...
  118. ../../lib/m4sugar/m4sh.m4:606: AS_IF is expanded from...
  119. ../../lib/autoconf/general.m4:2032: AC_CACHE_VAL is expanded from...
  120. ../../lib/autoconf/general.m4:2053: AC_CACHE_CHECK is expanded from...
  121. configure.ac:404: the top level
  122. Now run ./configure and gmake
  123. checking for a BSD-compatible install... /bin/install -c
  124. checking whether build environment is sane... yes
  125. checking for a thread-safe mkdir -p... /bin/mkdir -p
  126. checking for gawk... gawk
  127. checking whether make sets $(MAKE)... yes
  128. checking for pkg-config... /usr/bin/pkg-config
  129. checking pkg-config is at least version 0.20... yes
  130. checking build system type... i686-pc-linux-gnu
  131. checking host system type... i686-pc-linux-gnu
  132. checking for samba 4... /opt/samba4
  133. checking for style of include used by make... GNU
  134. checking for gcc... gcc
  135. checking whether the C compiler works... yes
  136. checking for C compiler default output file name... a.out
  137. checking for suffix of executables...
  138. checking whether we are cross compiling... no
  139. checking for suffix of object files... o
  140. checking whether we are using the GNU C compiler... yes
  141. checking whether gcc accepts -g... yes
  142. checking for gcc option to accept ISO C89... none needed
  143. checking dependency style of gcc... none
  144. checking how to run the C preprocessor... gcc -E
  145. checking for grep that handles long lines and -e... /bin/grep
  146. checking for egrep... /bin/grep -E
  147. checking for ANSI C header files... yes
  148. checking for sys/types.h... yes
  149. checking for sys/stat.h... yes
  150. checking for stdlib.h... yes
  151. checking for string.h... yes
  152. checking for memory.h... yes
  153. checking for strings.h... yes
  154. checking for inttypes.h... yes
  155. checking for stdint.h... yes
  156. checking for unistd.h... yes
  157. checking sys/cdefs.h usability... yes
  158. checking sys/cdefs.h presence... yes
  159. checking for sys/cdefs.h... yes
  160. checking for string.h... (cached) yes
  161. checking sys/sockio.h usability... no
  162. checking sys/sockio.h presence... no
  163. checking for sys/sockio.h... no
  164. checking for strcasestr... yes
  165. checking for comparison_fn_t... yes
  166. checking for gcc... (cached) gcc
  167. checking whether we are using the GNU C compiler... (cached) yes
  168. checking whether gcc accepts -g... (cached) yes
  169. checking for gcc option to accept ISO C89... (cached) none needed
  170. checking dependency style of gcc... (cached) none
  171. checking whether we are really using the Sun C compiler... no
  172. checking whether we are really using the Intel C compiler... no
  173. checking for perl... /usr/bin/perl
  174. checking for pidl... /opt/samba4/bin/pidl
  175. checking for python... /tmp/yaourt-tmp-root/aur-openchange/src/bin/python
  176. checking for python-config... /tmp/yaourt-tmp-root/aur-openchange/src/bin/python-config
  177. checking python library directory... ${prefix}/lib/python2.7/site-packages
  178. checking for TALLOC... yes
  179. checking for SAMBA... yes
  180. checking for TDB... yes
  181. checking for LDB... yes
  182. checking samba/version.h usability... yes
  183. checking samba/version.h presence... yes
  184. checking for samba/version.h... yes
  185. checking for pthread_mutex_init in -lpthread... yes
  186. checking for g++... g++
  187. checking whether we are using the GNU C++ compiler... yes
  188. checking whether g++ accepts -g... yes
  189. checking dependency style of g++... none
  190. checking C++ compiler availability... yes
  191. checking for boost_thread-mt library... yes
  192. checking whether we are using the GNU C++ compiler... (cached) yes
  193. checking whether g++ accepts -g... (cached) yes
  194. checking dependency style of g++... (cached) none
  195. checking for SAMR... yes
  196. checking for ICAL... yes
  197. checking for poptFreeContext in -lpopt... yes
  198. checking for smbtorture... /opt/samba4/bin/smbtorture
  199. checking for magic_open in -lmagic... yes
  200. checking for gzopen in -lz... yes
  201. checking for SQLITE... yes
  202. checking for doxygen... no
  203. configure: WARNING: doxygen
  204. checking for SUBUNIT... no
  205. configure: creating ./config.status
  206. config.status: creating config.mk
  207. config.status: creating libmapi.pc
  208. config.status: creating libmapiadmin.pc
  209. config.status: creating libocpf.pc
  210. config.status: creating mapiproxy/libmapiproxy.pc
  211. config.status: creating mapiproxy/libmapiserver.pc
  212. config.status: creating mapiproxy/libmapistore.pc
  213. config.status: creating libmapi++.pc
  214. config.status: creating Doxyfile
  215. config.status: creating libmapi++/Doxyfile
  216. config.status: creating libocpf/Doxyfile
  217. config.status: creating libmapiadmin/Doxyfile
  218. config.status: creating libmapi/Doxyfile
  219. config.status: creating mapiproxy/Doxyfile
  220. config.status: creating utils/mapitest/Doxyfile
  221. config.status: creating config.h
  222. config.status: executing depfiles commands
  223.  
  224.  
  225. ===============================================================
  226. OpenChange Configuration (Please review)
  227.  
  228.            * Install:
  229.              - prefix:                  /opt/samba4
  230.  
  231.            * OpenChange MAPI library:   yes
  232.                       Thread support:   yes (pthread)
  233.  
  234.            * OpenChange Libraries:
  235.              - libmapi++:               yes
  236.              - libmapiadmin:            yes
  237.              - libocpf:                 yes
  238.  
  239.            * OpenChange Server:
  240.              - mapiproxy:               yes
  241.  
  242.            * OpenChange mapistore backends:
  243.              - sqlite3:                 yes
  244.  
  245.            * OpenChange Tools:
  246.              - openchangeclient:        yes
  247.              - mapiprofile:             yes
  248.              - openchangepfadmin:       yes
  249.              - exchange2mbox:           yes
  250.              - exchange2ical:           yes
  251.              - mapitest:                yes
  252.              - openchangemapidump:      yes
  253.              - schemaIDGUID:            yes
  254.  
  255.            * OpenChange Torture Suite:  yes
  256.  
  257.            * subunit format (mapitest): no
  258.  
  259.            * OpenChange Documentation:  no
  260.  
  261.            * Coverage Tests:            no
  262.  
  263.            * OpenChange Bindings:
  264.              - Perl:                    no
  265.              - Python:                  no
  266.              - Qt4:                     no
  267.  
  268.  
  269. ===============================================================
  270.  
  271.  
  272. Creating the gen_ndr directory
  273. mkdir -p gen_ndr
  274. Generating exchange.h
  275. Compiling exchange.idl
  276. exchange.idl:1258: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  277. exchange.idl:1365: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  278. exchange.idl:1431: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  279. exchange.idl:1457: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  280. exchange.idl:1722: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  281. exchange.idl:2121: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  282. exchange.idl:2131: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  283. exchange.idl:2216: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  284. exchange.idl:2232: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  285. exchange.idl:2336: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  286. exchange.idl:2342: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  287. exchange.idl:2385: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  288. exchange.idl:2774: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  289. exchange.idl:3267: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  290. exchange.idl:3387: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  291. exchange.idl:3814: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  292. exchange.idl:3815: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  293. exchange.idl:4242: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  294. exchange.idl:3812: warning: [out] argument `size' not a pointer
  295. exchange.idl:3813: warning: [out] argument `offset' not a pointer
  296. Generating gen_ndr/ndr_exchange.h
  297. Compiling exchange.idl
  298. exchange.idl:1258: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  299. exchange.idl:1365: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  300. exchange.idl:1431: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  301. exchange.idl:1457: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  302. exchange.idl:1722: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  303. exchange.idl:2121: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  304. exchange.idl:2131: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  305. exchange.idl:2216: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  306. exchange.idl:2232: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  307. exchange.idl:2336: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  308. exchange.idl:2342: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  309. exchange.idl:2385: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  310. exchange.idl:2774: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  311. exchange.idl:3267: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  312. exchange.idl:3387: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  313. exchange.idl:3814: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  314. exchange.idl:3815: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  315. exchange.idl:4242: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  316. exchange.idl:3812: warning: [out] argument `size' not a pointer
  317. exchange.idl:3813: warning: [out] argument `offset' not a pointer
  318. Generating property.h
  319. Compiling property.idl
  320. Generating gen_ndr/ndr_property.h
  321. Compiling property.idl
  322. ./script/mkversion.sh: 'libmapi/version.h' created for OpenChange libmapi("0.10 (Nomad)")
  323. Generating gen_ndr/ndr_exchange_c.h
  324. Compiling exchange.idl
  325. exchange.idl:1258: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  326. exchange.idl:1365: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  327. exchange.idl:1431: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  328. exchange.idl:1457: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  329. exchange.idl:1722: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  330. exchange.idl:2121: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  331. exchange.idl:2131: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  332. exchange.idl:2216: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  333. exchange.idl:2232: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  334. exchange.idl:2336: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  335. exchange.idl:2342: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  336. exchange.idl:2385: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  337. exchange.idl:2774: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  338. exchange.idl:3267: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  339. exchange.idl:3387: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  340. exchange.idl:3814: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  341. exchange.idl:3815: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  342. exchange.idl:4242: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
  343. exchange.idl:3812: warning: [out] argument `size' not a pointer
  344. exchange.idl:3813: warning: [out] argument `offset' not a pointer
  345. exchange.idl:3812: error: EcDoRpc: [out] argument 'size' is not a pointer or array, skip client functions
  346. Compiling libmapi/emsmdb.c with -fPIC
  347. Compiling libmapi/IABContainer.c with -fPIC
  348. Compiling libmapi/IProfAdmin.c with -fPIC
  349. Compiling libmapi/IMAPIContainer.c with -fPIC
  350. Compiling libmapi/IMAPIFolder.c with -fPIC
  351. Compiling libmapi/IMAPIProp.c with -fPIC
  352. Compiling libmapi/IMAPISession.c with -fPIC
  353. Compiling libmapi/IMAPISupport.c with -fPIC
  354. Compiling libmapi/IStream.c with -fPIC
  355. Compiling libmapi/IMAPITable.c with -fPIC
  356. Compiling libmapi/IMessage.c with -fPIC
  357. Compiling libmapi/IMsgStore.c with -fPIC
  358. Compiling libmapi/IStoreFolder.c with -fPIC
  359. Compiling libmapi/IUnknown.c with -fPIC
  360. Compiling libmapi/IMSProvider.c with -fPIC
  361. Compiling libmapi/IXPLogon.c with -fPIC
  362. Compiling libmapi/FXICS.c with -fPIC
  363. Compiling libmapi/utils.c with -fPIC
  364. Compiling libmapi/property.c with -fPIC
  365. Compiling libmapi/cdo_mapi.c with -fPIC
  366. Compiling libmapi/lzfu.c with -fPIC
  367. Compiling libmapi/mapi_object.c with -fPIC
  368. Compiling libmapi/mapi_id_array.c with -fPIC
  369. Compiling libmapi/mapitags.c with -fPIC
  370. Compiling libmapi/mapidump.c with -fPIC
  371. libmapi/mapidump.c: In function ‘mapidump_Recipients’:
  372. libmapi/mapidump.c:216:3: warning: case value ‘0’ not in enumerated type ‘enum MAPITAGS’
  373. libmapi/mapidump.c:219:3: warning: case value ‘1’ not in enumerated type ‘enum MAPITAGS’
  374. libmapi/mapidump.c:222:3: warning: case value ‘2’ not in enumerated type ‘enum MAPITAGS’
  375. Compiling libmapi/mapicode.c with -fPIC
  376. Compiling libmapi/codepage_lcid.c with -fPIC
  377. Compiling libmapi/mapi_nameid.c with -fPIC
  378. Compiling libmapi/nspi.c with -fPIC
  379. Compiling libmapi/simple_mapi.c with -fPIC
  380. Compiling libmapi/freebusy.c with -fPIC
  381. Compiling libmapi/x500.c with -fPIC
  382. Compiling ndr_mapi.c with -fPIC
  383. Compiling gen_ndr/ndr_exchange.c with -fPIC
  384. Compiling gen_ndr/ndr_exchange_c.c with -fPIC
  385. Compiling gen_ndr/ndr_property.c with -fPIC
  386. Compiling libmapi/socket/interface.c with -fPIC
  387. Compiling libmapi/socket/netif.c with -fPIC
  388. Linking libmapi.so.0.10
  389. /usr/bin/ld: cannot find -lldb
  390. collect2: ld returned 1 exit status
  391. make: *** [libmapi.so.0.10] Error 1
  392.  
  393.     openchange
clone this paste RAW Paste Data