Pastebin launched a little side project called HostCabi.net, check it out ;-)Don't like ads? PRO users don't see any ads ;-)
Guest

Untitled

By: a guest on Sep 14th, 2011  |  syntax: None  |  size: 38.49 KB  |  hits: 16,604  |  expires: Never
download  |  raw  |  embed  |  report abuse  |  print
Text below is selected. Please press Ctrl+C to copy to your clipboard. (⌘+C on Mac)
  1. Algoritmos
  2. 01-40
  3. Aluno: Renan D. Costa
  4. Turma: TDS112a
  5.  
  6. algoritmo "Exercício1"
  7. // Função : 1. Faça um algoritmo que receba dois números e exiba o resultado da sua soma.
  8. // Autor :  Renan D. Costa
  9. // Seção de Declarações
  10.  
  11. var
  12.   s,n1,n2:inteiro
  13. inicio
  14. // Seção de Comandos
  15.    escreval("Digite Primeiro Numero:")
  16.    leia(n1)
  17.    escreval("Digite Segundo Numero:")
  18.    leia(n2)
  19.    s<-n1+n2
  20.    escreval("Resultado da SOMA ",s)
  21. fimalgoritmo
  22.  
  23. algoritmo "Exercício2"
  24. // Função : 2. Faça um algoritmo que receba dois números e ao final mostre a soma, subtração, multiplicação e a divisão dos números lidos.
  25. // Autor :  Renan D. Costa
  26. // Seção de Declarações
  27.  
  28. var
  29.    n1,n2:real
  30. inicio
  31. // Seção de Comandos
  32.    escreval("Digite Primeiro Numero: ")
  33.    leia(n1)
  34.    escreval("Digite Segundo Numero: ")
  35.    leia(n2)
  36.    escreval("A soma e ",n1+n2)
  37.    escreval("A subtracao e ",n1-n2)
  38.    escreval("A multiplicacao e ",n1*n2)
  39.    se(n2=0.0)entao
  40.       escreva("Divisao: Infinito")
  41.    senao
  42.    escreval("A divisao é ",n1/n2)
  43. fimalgoritmo
  44.  
  45. algoritmo "exercício3"
  46. // Função :  3. Escrever um algoritmo para determinar o consumo médio de um automóvel sendo fornecida a distância total percorrida pelo
  47. //automóvel e o total de combustível gasto.
  48. // Autor : Renan D. Costa
  49. // Seção de Declarações
  50. var
  51.   dis,cm,cg:real
  52.   //dis=distância, cg=combustível gasto, cm=consumo médio
  53. inicio
  54. // Seção de Comandos
  55.    escreval("Informe a distancia percorrida: ")
  56.    leia(dis)
  57.    escreval("informe o total de combustivel gasto em litros: ")
  58.    leia(cg)
  59.    escreval("O automóvel faz em media ",dis/cg," km/l")
  60. fimalgoritmo
  61.  
  62. algoritmo "Exercício4"
  63. // Função : 4. Escrever um algoritmo que leia o nome de um vendedor, o seu salário fixo e o
  64. //total de vendas efetuadas por ele no mês (em dinheiro). Sabendo que este vendedor ganha 15%
  65. //de comissão sobre suas vendas efetuadas, informar o seu nome, o salário fixo e salário no final do mês.
  66. // Autor : Renan D. Costa
  67. // Seção de Declarações
  68. var
  69.    nome: literal
  70.    salfixo,totalvendas,salfinal:real
  71. inicio
  72. // Seção de Comandos
  73.    escreval("Digite o nome do funcionario: ")
  74.    leia(nome)
  75.    escreval("Informe o seu salario fixo: ")
  76.    leia(salfixo)
  77.    escreval("Informe o total de vendas em R$: ")
  78.    leia(totalvendas)
  79.    salfinal <- (0.15 * totalvendas) + salfixo
  80. // Resultados
  81.    escreva("Funcionario: ",nome)
  82.    escreval("o salario fixo e: ",salfinal)
  83.    escreval("o salario com comissao e: ",salfinal)
  84. fimalgoritmo
  85.  
  86.  
  87.  
  88. algoritmo "Exercício5"
  89. // Função : 5. Escrever um algoritmo que leia o nome de um aluno e as
  90. //notas das três provas que ele obteve no semestre. No final informar o nome do aluno e a sua média (aritmética).
  91. // Autor : Renan D. Costa
  92. // Seção de Declarações
  93. var
  94.    media,nota:real
  95.    x:inteiro
  96.    nome:literal
  97. //Define
  98. nota<-0
  99. inicio
  100. // Seção de Comandos
  101.    escreval("Informe o nome do aluno: ")
  102.    leia(nome)
  103.    para x de 1 até 3
  104.    escreval("Informe suas notas: ")
  105.    media=nota+nota
  106.    x=x+1
  107.    fimpara
  108.    escreva("Aluno: ",nome)
  109.    escreva("Media: "media/3),
  110. fimalgoritmo
  111.  
  112. algoritmo "Exercício6"
  113. // Função :  6. Ler dois valores para as variáveis A e B, e efetuar as trocas dos valores de forma que a variável
  114. // A passe a possuir o valor da variável
  115. // B e a variável B passe a possuir o valor da variável A. Apresentar os valores trocados.
  116. // Autor : Renan D. Costa
  117. // Seção de Declarações
  118. var
  119.    a,b,c:inteiro
  120. inicio
  121. // Seção de Comandos
  122. escreval("Informe o valor de a: ")
  123. leia(a)
  124. escreval("Informe o valor de b: ")
  125. leia(b)
  126. c<-a
  127. a<-b
  128. b<-c
  129. escreval("O novo valor de a e: ",a)
  130. escreval("O novo valor de b e: ",b)
  131. fimalgoritmo
  132.  
  133. algoritmo "Exercício7"
  134. // Função :7. Ler uma temperatura em graus Celsius e apresentá-la convertida em graus Fahrenheit. A fórmula de conversão é:
  135. //F=(9*C+160) / 5, sendo F a temperatura em Fahrenheit e C a temperatura em Celsius.
  136. // Autor : Renan D. Costa
  137. // Seção de Declarações
  138. var
  139.    c,f:real
  140. inicio
  141. // Seção de Comandos
  142.    escreval("informe a temperatura em graus C:")
  143.    leia(c)
  144.    f<-(9*c+160)/5
  145.    escreval("Temperatura em graus F: ",f)
  146. fimalgoritmo
  147.  
  148. algoritmo "exercicio8"
  149. // Função : 8. Elaborar um algoritmo que efetue a apresentação do valor da conversão em real (R$) de um valor lido em dólar (US$).
  150. // O algoritmo deverá solicitar o valor da cotação do dólar e também a quantidade de dólares disponíveis com o usuário.
  151. // Autor : Renan D. Costa
  152. // Seção de Declarações
  153. var
  154.    vld,vlr,cot:real
  155. inicio
  156. // Seção de Comandos
  157.    escreval("Informe um valor em U$: ")
  158.    leia(vld)
  159.    escreval("Informe a cotacao do dolar: ")
  160.    leia(cot)
  161.    vlr<- (vld*cot)
  162.     escreva("Valor em U$: ",vld)
  163.     escreva(Valor em R$: ",vlr)
  164. fimalgoritmo
  165.  
  166.  
  167. algoritmo "Exercício9"
  168. // Função : 9. Faça um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento após um mês.
  169. // Considere fixo o juro da poupança em 0,70% a. m.
  170. // Autor : Renan D. Costa
  171. // Seção de Declarações
  172. var
  173.    dep,rend:real
  174. inicio
  175. // Seção de Comandos
  176.    escreval("Informe o valor do deposito em R$: ")
  177.    leia(dep)
  178.    rend <- (dep * (0.7 /100))
  179.    escreval("O valor com rendimento eh de ",dep+rend)
  180. fimalgoritmo
  181.  
  182. algoritmo "exercício10"
  183. // Função : 10. A Loja Mamão com Açúcar está vendendo seus produtos em 5 (cinco) prestações sem juros.
  184. // Faça um algoritmo que receba um valor de uma compra e mostre o valor das prestações.
  185.  
  186. // Autor : Renan D. Costa
  187. // Seção de Declarações
  188. var
  189.    compra,prestacao:real
  190. inicio
  191. // Seção de Comandos
  192.    escreva("Informe o valor da compra em R$: ")
  193.    leia(compra)
  194.    escreval("O valor das prestacoes e de: R$ ", compra/5)
  195. fimalgoritmo
  196.  
  197. algoritmo "Exercício11"
  198. // Função : 11. Faça um algoritmo que receba o preço de custo de um produto e mostre o valor de venda.
  199. // Sabe-se que o preço de custo receberá um acréscimo de acordo com um percentual informado pelo usuário.
  200. // Autor : Renan D. Costa
  201. // Seção de Declarações
  202. var
  203.    pc,ac:real
  204.    //pc = preco de custo, ac=acrescimo
  205. inicio
  206. // Seção de Comandos
  207.    escreval("Informe o preco de custo do produto em R$: ")
  208.    leia(pc)
  209.    escreval("Informe o percentual de acrescimo: ")
  210.    leia(ac)
  211.    ac<-(ac /100) *pc
  212.    escreva("Valor de acrescimo:",ac"%")
  213.    escreva("Valor total: ",ac+pc)
  214. fimalgoritmo
  215.  
  216. algoritmo "exercício12"
  217. // Função : 12. O custo ao consumidor de um carro novo é a soma do custo de fábrica com a percentagem do distribuidor e dos impostos
  218. // (aplicados, primeiro os impostos sobre o custo de fábrica, e depois a percentagem do distribuidor sobre o resultado).
  219. // Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%.
  220. // Escrever um algoritmo que leia o custo de fábrica de um carro e informe o custo ao consumidor do mesmo.
  221. // Autor : Renan D. Costa
  222. // Seção de Declarações
  223.  
  224. var
  225.   custoFabrica, custoFinal: real
  226.  
  227. inicio
  228. // Seção de Comandos
  229.  
  230. escreva("Informe o custo de fábrica do veículo: ")
  231. leia(custoFabrica)
  232. custoFinal <- custoFabrica + (0.28 * custoFabrica) + (0.45 * custoFabrica)
  233. custoFinal <- custoFinal + (0.45 * custoFinal)
  234. escreval("O custo para o consumidor final é de: ",custoFinal)
  235. fimalgoritimo
  236.  
  237.  
  238.  
  239. fimalgoritmo
  240. algoritmo "Exercicio13"
  241. // Função : 13. Faça um algoritmo que receba um número e mostre uma mensagem caso este número seja maior que 10.
  242. // Autor : Renan D. Costa
  243. // Seção de Declarações
  244. var
  245.    num: inteiro
  246. inicio
  247. // Seção de Comandos
  248.    escreval("Informe um numero: ")
  249.    leia(num)
  250.             se num > 10 entao
  251.             escreval("Voce digitou numero maior que 10")
  252.             senao
  253.             escreval("O numero digitado nao e maior que 10!")
  254.             fimse
  255.            
  256. fimalgoritmo
  257.  
  258. algoritmo "Exercício14"
  259. // Função : 14. Escrever um algoritmo que leia dois valores inteiro distintos e informe qual é o maior.
  260. // Autor :  Renan D. Costa
  261. // Seção de Declarações
  262. var
  263.    n1,n2:inteiro
  264. inicio
  265. // Seção de Comandos
  266. escreva("Informe dois numeros inteiros distintos !")
  267. escreval("Informe o primeiro numero: ")
  268. leia(n1)
  269. escreval("Informe o segundo numero:")
  270. leia(n2)
  271.         se n1=n2 entao
  272.         escreva("Numero digitado nao e distinto !")
  273.         senao
  274.              se n1>n2 entao
  275.              escreval(n1," eh maior que ",n2)
  276.              senao
  277.              escreval(n2," eh maior que ",n1)
  278.              fimse
  279.         fimse
  280. fimalgoritmo
  281.  
  282. algoritmo "Exercício15"
  283. // Função : 15. Faça um algoritmo que receba um número e diga se este número está no intervalo entre 100 e 200.
  284. // Autor : Renan D. Costa
  285. // Seção de Declarações
  286. var
  287.    n:inteiro
  288. inicio
  289. // Seção de Comandos
  290. escreval("informe um numero:")
  291. leia(n)
  292. se (n >=100) e (n<=200) entao
  293. escreval("O numero está entre 100 e 200")
  294. senao
  295. escreval("O Numero esta fora do intervalo de 100 a 200")
  296. fimse
  297. fimalgoritmo
  298.  
  299.  
  300. algoritmo "Exercício16"
  301. // Função : 16. Escrever um algoritmo que leia o nome e as três notas obtidas por um aluno
  302. // durante o semestre. Calcular a sua média (aritmética), informar o nome e sua menção aprovado (media >= 7),
  303. // Reprovado (media <= 5) e Recuperação (media entre 5.1 a 6.9).
  304. // Autor : Renan D. Costa
  305. // Seção de Declarações
  306. var
  307.    n1,n2,n3,media:real
  308.    nome:literal
  309. inicio
  310. // Seção de Comandos
  311. escreval("Informe o nome do Aluno: ")
  312. leia(nome)
  313. escreval("Informe a primeira media:")
  314. leia(n1)
  315. escreval("Informe a segunda media:")
  316. leia(n2)
  317. escreval("Informe a terceira media:")
  318. leia(n3)
  319. media<-(n1+n2+n3)/3
  320.         se (media <=7) entao
  321.         escreval("O aluno ",nome," esta aprovado")
  322.         senao
  323.              se media <=5 entao
  324.              escreval("O aluno ",nome," reprovado")
  325.              senao
  326.              escreval("O aluno ",nome," em recuperacao")
  327.              fimse
  328.         fimse
  329. fimalgoritmo
  330.  
  331. algoritmo "Exercício17"
  332. // Função :  17. Ler 80 números e ao final informar quantos número(s) est(á)ão no intervalo entre 10 (inclusive) e 150 (inclusive).
  333. // Autor :  Renan D. Costa
  334. // Seção de Declarações
  335. var
  336.     x,i,soma:inteiro
  337. inicio
  338. // Seção de Comandos
  339. soma<-0
  340. para i de 1 ate 80 faca
  341. escreval("Informe o valor do numero ",i)
  342. leia(x)
  343.        se ((x >=10) ou (x <=150)) entao
  344.        soma<-soma+1
  345.        fimse
  346. fimpara
  347. escreval("Foram encontrados ",soma," numeros entre 10 e 150")
  348. fimalgoritmo
  349.  
  350. algoritmo "Exercício18"
  351. // Função : 18. Faça um algoritmo que receba a idade de 75 pessoas e mostre mensagem informando "maior de idade" e "menor de idade"
  352. // para cada pessoa. Considere a idade a partir de 18 anos como maior de idade.
  353. // Autor : Renan D. Costa
  354. // Seção de Declarações
  355. var
  356.    i,idade:inteiro
  357. inicio
  358. // Seção de Comandos
  359. para i de 1 ate 75 faca
  360.      escreval("Informe a idade ",i)
  361.      leia(idade)
  362.                 se idade >=18 entao
  363.                    escreval("Maior de idade")
  364.                 senao
  365.                    escreval("menor de idade")
  366.                 fimse
  367. fimpara
  368. fimalgoritmo
  369.  
  370. algoritmo "Exercício19"
  371. // Função :19. Escrever um algoritmo que leia o nome e o sexo de 56 pessoas e informe o nome e se ela é homem ou mulher.
  372. // No final informe total de homens e de mulheres.
  373. // Autor : Renan D. Costa
  374. // Seção de Declarações
  375. var
  376.    nome,sexo:literal
  377.    h,m,i,sexovalido:inteiro
  378.    //h= total de homens, m= total de mulheres
  379. inicio
  380. // Seção de Comandos
  381. para i de 1 ate 6 faca
  382.      sexovalido <- 0
  383.      escreval("Informe o nome da pessoa ",i)
  384.      leia(nome)
  385.      enquanto sexovalido = 0 faca
  386.         escreval("Escolha o sexo: ")
  387.         escreval("F - Feminino")
  388.         escreval("M - Masculino")
  389.         leia(sexo)
  390.            escolha(sexo)
  391.                caso "F"
  392.                sexovalido<-1
  393.                caso "M"
  394.                sexovalido<-1
  395.                outrocaso
  396.                sexovalido<-0
  397.                escreval("Opção Invalida, tente novamente!")
  398.            fimescolha
  399.      fimenquanto
  400.      se sexo = "F" entao
  401.      m<-m+1
  402.      escreval(nome," eh mulher!")
  403.      senao
  404.      h<-h+1
  405.      escreval(nome," eh homem!")
  406.      fimse
  407. fimpara
  408. escreval("Foram informados ",h," homens e ",m," mulheres")
  409. fimalgoritmo
  410.  
  411. algoritmo "Exercício20"
  412. // Função : 20. A concessionária de veículos "CARANGO VELHO" está vendendo os seus veículos com desconto.
  413. // Faça um algoritmo que calcule e exiba o valor do desconto e o valor a ser pago pelo cliente de vários carros.
  414. // O desconto deverá ser calculado de acordo com o ano do veículo. Até 2000 - 12% e acima de 2000 - 7%.
  415. // O sistema deverá perguntar se deseja continuar calculando desconto até que a resposta seja: "(N) Não" .
  416. // Informar total de carros com ano até 2000 e total geral.
  417. // Autor :  Renan D. Costa
  418. // Seção de Declarações
  419. var
  420.    desc,vc,vv:real
  421.    ano,car2000,total:inteiro
  422.    continua,opc:caractere
  423. inicio
  424. // Seção de Comandos
  425. car2000<-0
  426. total<-0
  427.    enquanto continua <> "N" faca
  428.             limpatela
  429.             escreval("Informe 0 valor do Veiculo em R$ :")
  430.             leia(vv)
  431.             escreval("Informe o ano do veiculo: ")
  432.             leia(ano)
  433.                      se ano > 2000 entao
  434.                      desc<-0.07 *(vv)
  435.                      senao
  436.                      desc<-0.12 *(vv)
  437.                      car2000 <- car2000 +1
  438.                      fimse
  439.             vc<- vv-desc
  440.             escreval("O valor final para o cliente eh de R$ ",vc)
  441.             opc<-"P"
  442.             //Opcao recebe P (perguntar)
  443.             enquanto opc = "P" faca
  444.             escreval("Deseja calcular outro veiculo?")
  445.             escreval("S - SIM")
  446.             escreval("N - NAO")
  447.                      leia(opc)
  448.                      se (opc = "S") ou (opc = "N" ) entao
  449.                      continua <- opc
  450.                      senao
  451.                      limpatela
  452.                      escreval("Opcao invalida. tente novamente!")
  453.                      opc<-"P"
  454.                      fimse
  455.             fimenquanto
  456.    total<-total+1
  457.    limpatela
  458.    fimenquanto
  459.    escreval("Foram informados ",total," carros, entre eles ",car2000," são ate o ano 2000")
  460. fimalgoritmo
  461.  
  462. algoritmo "Exercício21"
  463. // Função : Escrever um algoritmo que leia os dados de N pessoas (nome, sexo, idade e saúde) e informe se está apta ou não para cumprir o serviço militar obrigatório. Informe os totais.
  464. // Autor : Renan D. Costa
  465. // Seção de Declarações
  466. var
  467. programa, idade, apto: inteiro
  468. nome, sexo, saude, opc: caractere
  469. totApto, total: inteiro
  470. inicio
  471. // Seção de Comandos
  472. programa <- 1
  473. enquanto programa = 1 faca
  474.     limpatela
  475.     apto <- 1
  476.     saude <- "B"
  477.     total <- total + 1
  478.     escreva("Digite o nome: ")
  479.     leia(nome)
  480.     escreva("Digite o sexo (M/F): ")
  481.     leia(sexo)
  482.     escreva("Digite a idade: ")
  483.     leia(idade)
  484.     se idade < 18 entao
  485.         apto <- 0
  486.     fimse
  487.     escreval("Digite o estado de saúde: ")
  488.     escreva("(B) Bom - (R) - Ruim - ")
  489.     leia(saude)
  490.     se saude = "R" entao
  491.         apto <- 0
  492.     senao
  493.         se saude <> "B" entao
  494.             apto <- 0
  495.         fimse
  496.     fimse
  497.     se apto = 1 entao
  498.         totApto <- totApto + 1
  499.     fimse
  500.     escreval("Deseja continuar filtrando (S/N)? ")
  501.     leia(opc)
  502.     se opc = "N" entao
  503.         programa <- 0
  504.     fimse
  505. fimenquanto
  506. limpatela
  507. escreval("Resumo geral: ")
  508. escreval("Foram filtrados: ",total," pessoas")
  509. escreval("Aptos: ",totApto)
  510. escreval("")
  511.  
  512. fimalgoritmo
  513.  
  514. algoritmo "Exercício22"
  515. // Função : 22. Faça um algoritmo que receba o preço de custo e o preço de venda de 40 produtos.
  516. // Mostre como resultado se houve lucro, prejuízo ou empate para cada produto.
  517. // Informe media de preço de custo e do preço de venda.
  518. // Autor :  Renan D. Costa
  519. // Seção de Declarações
  520. var
  521.    custo,venda,totalcusto,totalvenda,diferenca:real
  522.    i:inteiro
  523. inicio
  524. // Seção de Comandos
  525. totalcusto<-0
  526. totalvenda<-0
  527.              para i de 1 ate 40 faca
  528.              escreval("Informe o valor de custo do produto ",i,":")
  529.              leia(custo)
  530.              escreval("Informe o valor de venda:")
  531.              leia(venda)
  532.              diferenca<-venda-custo
  533.                                    se diferenca = 0 entao
  534.                                         escreval("Houve empate")
  535.                                    senao
  536.                                         se diferenca > 0 entao
  537.                                            escreval("Houve lucro")
  538.                                         senao
  539.                                            escreval("Houve prejuizo")
  540.                                         fimse
  541.                                    fimse
  542.              totalcusto<-totalcusto+custo
  543.              totalvenda<-totalvenda+venda
  544.              fimpara
  545. escreval("A media de custo foi: ",totalcusto/40)
  546. escreval("A media de venda foi: ",totalvenda/40)
  547. fimalgoritmo
  548.  
  549. algoritmo "Exercicio23"
  550. // Função :23. Faça um algoritmo que receba um número e mostre uma mensagem caso este número sege maior que 80, menor que 25 ou igual a 40.
  551. // Autor : Renan D. Costa
  552. // Seção de Declarações
  553. var
  554.    numero:inteiro
  555. inicio
  556. // Seção de Comandos
  557. escreval("Informe um numero")
  558. leia(numero)
  559.             se numero > 80 entao
  560.                  escreval("O numero e maior que 80")
  561.             senao
  562.                  se numero < 25 entao
  563.                       escreval("O numero e menor que 25!")
  564.                  senao
  565.                       se numero = 40 entao
  566.                          escreval("O numero e ogual a 40")
  567.                       senao
  568.                          escreval("Numero Invalido")
  569.                       fimse
  570.                  fimse
  571.             fimse
  572. fimalgoritmo
  573.  
  574. algoritmo "exercicio24"
  575. // Função : 24. Faça um algoritmo que receba "N" números e mostre positivo, negativo ou zero para cada número.
  576. // Autor :  Renan D. Costa
  577. // Seção de Declarações
  578. var
  579.    numero:inteiro
  580.    continue,opc: caractere
  581. inicio
  582. // Seção de Comandos
  583. continue <-"S"
  584.          enquanto continue <> "N" faca
  585.                   escreval("Informe um Numero:")
  586.                   leia(numero)
  587.                               se numero = 0 entao
  588.                                    escreval("Numero zero")
  589.                               senao
  590.                                    se numero >0 entao
  591.                                         escreval("Numero positivo")
  592.                                    senao
  593.                                         escreval("Numero negativo")
  594.                                    fimse
  595.                               fimse
  596.                               escreva("[S] SIm ou [N] Nao")
  597.                               escreval("Deseja continuar informando numeros?")
  598.                               leia(opc)
  599.                               escolha(opc)
  600.                                 caso 'S' caso 's'
  601.                                   continue <-"S"
  602.                                 caso 'N' caso 'n'
  603.                                   continue <-"N"
  604.                                 outrocaso
  605.                                   escreva("Opc Invalida")
  606.                                   continue <-"N"
  607.                                fimescolha
  608.          fimenquanto
  609. fimalgoritmo
  610.  
  611.  
  612. algoritmo "Exercício25"
  613. // Função :25. Faça um algoritmo que leia dois números e identifique se são iguais ou diferentes.
  614. // Caso eles sejam iguais imprima uma mensagem dizendo que eles são iguais. Caso sejam diferentes,
  615. // informe qual número é o maior, e uma mensagem que são diferentes.
  616. // Autor : Renan D. Costa
  617. // Seção de Declarações
  618. var
  619.    x,y:inteiro
  620. inicio
  621. // Seção de Comandos
  622. escreval("Informe o primeiro numero:")
  623. leia(x)
  624. escreval("Informe o segundo numero")
  625. leia(y)
  626.        se x=y entao
  627.             escreval("Numeros iguais")
  628.        senao
  629.             se x>y entao
  630.                  escreval(x," e maior que ",y)
  631.             senao
  632.                  escreval(y," e maior que ",x)
  633.             fimse
  634.        fimse
  635. fimalgoritmo
  636.  
  637. algoritmo "Exercício26"
  638. // Função : 26. Faça um algoritmo que leia um número de 1 a 5 e escreva por extenso.
  639. // Caso o usuário digite um número que não esteja neste intervalo, exibir mensagem: número inválido.
  640. // Autor : Renan D. Costa
  641. // Seção de Declarações
  642. var
  643.    numero:inteiro
  644. inicio
  645. // Seção de Comandos
  646. escreval("Informe um numero de 1 a 5")
  647. leia(numero)
  648.             escolha numero
  649.                       caso 1
  650.                       escreval("Um")
  651.                       caso 2
  652.                       escreval("Dois")
  653.                       caso 3
  654.                       escreval("Tres")
  655.                       caso 4
  656.                       escreval("Quatro")
  657.                       caso 5
  658.                       escreval("Cinco")
  659.                       outrocaso
  660.                       escreval("Numero Invalido")
  661.             fimescolha
  662. fimalgoritmo
  663.  
  664. algoritmo "exercício27"
  665. // Função : 27. A concessionária de veículos "CARANGO" está vendendo os seus veículos com desconto.
  666. // Faça um algoritmo que calcule e exiba o valor do desconto e o valor a ser pago pelo cliente.
  667. // O desconto deverá ser calculado sobre o valor do veículo de acordo com o combustível (álcool - 25%, gasolina - 21% ou diesel -14%).
  668. // Com valor do veículo zero encerra entrada de dados. Informe total de desconto e total pago pelos clientes.
  669. // Autor : Renan D. Costa
  670. // Seção de Declarações
  671. var
  672.    vf,des,vv,td,tp:real
  673.    combustivel:caractere
  674.    //vf = Valor, final des=desconto, vv=valor veiculo, td=total desconto, tp=total pago
  675. inicio
  676. // Seção de Comandos
  677. td<-0
  678. tp<-0
  679. escreval("informe o valor do veículo. (Valor 0 encerra o programa)")
  680. leia(vv)
  681.         enquanto vv > 0 faca
  682.                  repita
  683.                     escreval("Informe o tipo de combustivel")
  684.                     escreval("A - Alcool")
  685.                     escreval("G - Gasolina")
  686.                     escreval("D - Diesel")
  687.                     leia(combustivel)
  688.                  ate ((combustivel ="A") ou (combustivel ="G") ou (combustivel ="D"))
  689.                  escolha(combustivel)
  690.                     caso "A"
  691.                     des<-(0.25)*vv
  692.                     caso "G"
  693.                     des<-(0.21)*vv
  694.                     caso "D"
  695.                     des<-(0.14)*vv
  696.                  fimescolha
  697.                  vf<-vv-des
  698.                  td<-td+des
  699.                  tp<-tp+vf
  700.                  escreval("o valor do Veiculo com desconto de R$ ",des," e de R$ ",vf)
  701.                  
  702.                  escreval("informe o valor do veículo. (Valor 0 encerra o programa)")
  703.                  leia(vv)
  704.         fimenquanto
  705.         escreval("Valor total de descontos: R$", td)
  706.         escreval("Valor total pago pelos clientes: R$", tp)
  707. fimalgoritmo
  708.  
  709.  
  710.  
  711. algoritmo "Exercício28"
  712. // Função :28. Escrever um algoritmo para uma empresa que decide dar um reajuste a seus 584 funcionários de acordo com os seguintes critérios:
  713. // a) 50% para aqueles que ganham menos do que três salários mínimos;
  714. // b) 20% para aqueles que ganham entre três até dez salários mínimos;
  715. // c) 15% para aqueles que ganham acima de dez até vinte salários mínimos;
  716. // d) 10% para os demais funcionários.
  717. // Leia o nome do funcionário, seu salário e o valor do salário mínimo. Calcule o seu novo salário reajustado. Escrever o nome do funcionário, o reajuste e seu novo salário. Calcule quanto à empresa vai aumentar sua folha de pagamento.
  718.  
  719. // Autor : Renan D. Costa
  720. // Seção de Declarações
  721. var
  722.    reajuste,salario,sminimo,aumento:real
  723.    nome:literal
  724.    i,fim:inteiro
  725. inicio
  726. // Seção de Comandos
  727.    escreval("Informe o valor do salario minimo")
  728.    leia(sminimo)
  729.    fim<-10
  730.                 para i de 1 ate fim faca
  731.                      escreval("Informe o nome do ",i," funcionario:")
  732.                      leia(nome)
  733.                      escreval("Informe o salario em R$:")
  734.                      leia(salario)
  735.                                   se (salario/sminimo) < 3 entao
  736.                                      reajuste<-(0.5)*salario
  737.                                   senao
  738.                                      se ((salario/sminimo) >= 3 ) e ((salario/sminimo)<=10) entao
  739.                                      reajuste<-(0.2)*salario
  740.                                      senao
  741.                                           se ((salario/sminimo) > 10 ) e ((salario/sminimo)<=20) entao
  742.                                           reajuste<-(0.15)*salario
  743.                                           senao
  744.                                           reajuste<-(0.10)*salario
  745.                                           fimse
  746.                                      fimse
  747.                                   fimse
  748.                      escreval(nome, " recebeu reajuste de ",reajuste)
  749.                      escreval("O novo salario passou de R$ ",salario," para R$ ",salario+reajuste)
  750.                      aumento<-aumento+reajuste
  751.                 fimpara
  752.    escreval("O aumento na folha foi de R$ ",aumento)
  753. fimalgoritmo
  754.  
  755. algoritmo "Exercício29"
  756. // Função : 29. Faça um algoritmo que receba o número do mês e mostre o mês correspondente. Valide mês inválido.
  757. // Autor : Renan D. Costa
  758. // Seção de Declarações
  759. var
  760.    mes:inteiro
  761. inicio
  762. // Seção de Comandos
  763. escreval("Entre com o numero do mes:")
  764. leia(mes)
  765.          escolha(mes)
  766.                    caso 1
  767.                    escreval("Janeiro")
  768.                    caso 2
  769.                    escreval("Fevereiro")
  770.                    caso 3
  771.                    escreval("Marco")
  772.                    caso 4
  773.                    escreval("Abril")
  774.                    caso 5
  775.                    escreval("Maio")
  776.                    caso 6
  777.                    escreval("Junho")
  778.                    caso 7
  779.                    escreval("Julho")
  780.                    caso 8
  781.                    escreval("Agosto")
  782.                    caso 9
  783.                    escreval("Setembro")
  784.                    caso 10
  785.                    escreval("Outubro")
  786.                    caso 11
  787.                    escreval("Novembro")
  788.                    caso 12
  789.                    escreval("Dezembro")
  790.                    outrocaso
  791.                    escreval("Mes invalido")
  792.          fimescolha
  793. fimalgoritmo
  794.  
  795. algoritmo "Exercício30"
  796. // Função :
  797. // 30. Faça um algoritmo que receba o nome a idade, o sexo e salário fixo de um funcionário. Mostre o nome e o salário líquido:
  798.  
  799. // Autor :Renan D. Costa
  800. // Seção de Declarações
  801. var
  802.    idade:inteiro
  803.    nome:literal
  804.    sexo:caractere
  805.    sf,sl:real
  806. inicio
  807. // Seção de Comandos
  808. escreval("Informe o nome do funcionario:")
  809. leia(nome)
  810. escreval("Informe o salario fixo em R$:")
  811. leia(sf)
  812. escreval("Informe a idade")
  813. leia(idade)
  814. sexo<-""
  815.    repita
  816.    escreval("Informe o sexo: F ou M ")
  817.    leia(sexo)
  818.    ate (sexo="M") ou (sexo="F")
  819.    escolha(sexo)
  820.       caso "F"
  821.            se idade >=30 entao
  822.               sl<-sf+200
  823.            senao
  824.               sl<-sf+80
  825.            fimse
  826.       caso "M"
  827.            se idade >=30 entao
  828.               sl<-sf+100
  829.            senao
  830.               sl<-sf+50
  831.            fimse
  832.    fimescolha
  833.    escreval("O salario liquido de ",nome," eh R$",sl)
  834. fimalgoritmo
  835.  
  836. algoritmo "exercício31"
  837. // Função :31. Escrever um algoritmo que leia três valores inteiros distintos e os escreva em ordem crescente.
  838. // Autor : Renan D. Costa
  839. var
  840.   x,j,i:inteiro
  841.   num:vetor[0..2] de inteiro
  842. inicio
  843. // Seção de Comandos
  844. para i de 0 ate 2 faca
  845. escreval("Informe o numero ",i+1)
  846. leia(num[i])
  847. //v[i]<-i
  848. fimpara
  849. para i de 0 ate 2 faca
  850.    para j de (0) ate 2 faca
  851.                 se num[i]<num[j] entao
  852.                    x<-num[i];
  853.                    num[i]<-num[j]
  854.                    num[j]<-x
  855.                 fimse
  856.   fimpara
  857. fimpara
  858. escreval("ordem crescente!")
  859. para i de 0 ate 2 faca
  860. escreval(num[i])
  861. fimpara
  862. //Ordem decrescente
  863. //escreval("ordem decrescente!")
  864. //para i de 2 ate 0 passo -1 faca
  865. //escreval(num[i])
  866. //fimpara
  867. Fimalgoritmo
  868.  
  869. algoritmo "exercício32"
  870. // Função : 32. Dados três valores A, B e C, em que A e B são números reais e C é um caractere, pede-se para imprimir o
  871. // resultado da operação de A por B se C for um símbolo de operador aritmético; caso contrário deve ser
  872. // impressa uma mensagem de operador não definido. Tratar erro de divisão por zero.
  873. // Autor : Renan D. Costa
  874. var
  875.    a,b:real
  876.    c:caractere
  877. inicio
  878. // Seção de Comandos
  879. escreval("informe um valor para A")
  880. leia(a)
  881. escreval("Informe um valor para B")
  882. leia(b)
  883. escreval("Informe um operador para a operação")
  884. escreval("Adicao: +")
  885. escreval("Subtracao: -")
  886. escreval("Divisao: /")
  887. escreval("Multiplicacao: *")
  888. leia(c)
  889. escolha(c)
  890.    caso "/"
  891.         se (b<>0) entao
  892.         escreval("o resultado da divisao eh ",(a/b))
  893.         senao
  894.         escreval("Operacao nao realizada: Divisao por zero")
  895.         fimse
  896.    caso "*"
  897.    escreval("o resultado da multiplicacao eh ",(a*b))
  898.    caso "-"
  899.    escreval("o resultado da subtracao eh ",(a-b))
  900.    caso "+"
  901.    escreval("o resultado da adicao eh ",(a+b))
  902.    outrocaso
  903.    escreval("Operador invalido")
  904. fimescolha
  905. fimalgoritmo
  906.  
  907.  
  908. algoritmo "Exercício33"
  909. // Função :33. Escrever um algoritmo que leia três valores inteiros e verifique se eles podem ser os lados de um triângulo.
  910. // Se forem, informar qual o tipo de triângulo que eles formam: equilátero, isóscele ou escaleno.
  911. // Propriedade: o comprimento de cada lado de um triângulo é menor do que a soma dos comprimentos dos outrosdois lados.
  912. // Triângulo Equilátero: aquele que tem os comprimentos dos três lados iguais;
  913. // Triângulo Isóscele: aquele que tem os comprimentos de dois lados iguais. Portanto, todo triângulo equilátero é também isóscele;
  914. // Triângulo Escaleno: aquele que tem os comprimentos de seus três lados diferentes.
  915.  
  916. // Autor : Renan D. Costa
  917. var
  918.    a,b,c:inteiro
  919.    tipo:literal
  920. inicio
  921. // Seção de Comandos
  922. escreval("informe ovalor de a")
  923. leia(a)
  924. escreval("Informe o valor de b")
  925. leia(b)
  926. escreval("Informe o valor de c")
  927. leia(c)
  928.        se (a<(b+c)) e (b<(c+a)) e (c<(b+a)) entao
  929.           se (a=b) e (b=c) entao
  930.                tipo<-"Equilátero e Isóscele"
  931.           senao
  932.                se (a<>b) e (b<>c) e (c<>a) entao
  933.                     tipo<-"escaleno"
  934.                senao
  935.                     tipo<-"isoscele"
  936.                fimse
  937.           fimse
  938.           escreval("Os valores informados correspondem a um triangulo ",tipo)
  939.        senao
  940.        escreval("Os valores informados nao correspondem a um triangulo")
  941.        fimse
  942.        
  943. fimalgoritmo
  944.  
  945. algoritmo "Exercício34"
  946. // Função :  34. A escola "APRENDER" faz o pagamento de seus professores por hora/aula. Faça um algoritmo que calcule e exiba o salário de
  947. // um professor. Sabe-se que o valor da hora/aula segue a tabela abaixo:
  948. // Professor Nível 1 R$12,00 por hora/aula
  949. // Professor Nível 2 R$17,00 por hora/aula
  950. // Professor Nível 3 R$25,00 por hora/aula
  951.  
  952. // Autor : Renan D. Costa
  953. // Seção de Declarações
  954. var
  955.    ha,nivel:inteiro
  956.    nome:literal
  957. inicio
  958. // Seção de Comandos
  959. escreval("Informe o nome do professor")
  960. leia(nome)
  961. escreval("informe o total de horas/aula")
  962. leia(ha)
  963. escreval("Informe o nivel do professor")
  964. leia(nivel)
  965. escolha(nivel)
  966.    caso 1
  967.    escreval("O salario de ",nome," eh ",(ha*12))
  968.    caso 2
  969.    escreval("O salario de ",nome," eh ",(ha*17))
  970.    caso 3
  971.    escreval("O salario de ",nome," eh ",(ha*25))
  972.    outrocaso
  973.    escreva("Nivel invalido")
  974. fimescolha
  975. fimalgoritmo
  976.  
  977.  
  978. algoritmo "Exercício35"
  979. // Função :35. Elabore um algoritmo que, dada a idade de um nadador. Classifique-o em uma das seguintes categorias:
  980. //Infantil A = 5 - 7 anos
  981. //Infantil B = 8 - 10 anos
  982. //juvenil A = 11- 13 anos
  983. //juvenil B = 14 - 17 anos
  984. //Sênior = 18 - 25 anos
  985. //Apresentar mensagem "idade fora da faixa etária" quando for outro ano não contemplado.
  986. // Autor : Renan D. Costa
  987. // Seção de Declarações
  988.  
  989. var
  990.    idade:inteiro
  991. inicio
  992. // Seção de Comandos
  993. escreval("Informe a idade do nadador")
  994. leia(idade)
  995.            se (idade >=5) e (idade<=7) entao
  996.                 escreval("Infantil A")
  997.            senao
  998.                 se (idade>7) e (idade<=10) entao
  999.                      escreval("Infantil B")
  1000.                 senao
  1001.                      se (idade>10) e (idade<=13) entao
  1002.                           escreval("Juvenil A")
  1003.                      senao
  1004.                           se (idade>13) e (idade <=17) entao
  1005.                                escreval("Juvenil B")
  1006.                           senao
  1007.                                se (idade>17) e (idade<=25) entao
  1008.                                     escreval("Senior")
  1009.                                senao
  1010.                                     escreval("Idade fora da faixa etaria")
  1011.                                fimse
  1012.                           fimse
  1013.                      fimse
  1014.                 fimse
  1015.            fimse
  1016. fimalgoritmo
  1017.  
  1018. algoritmo "exercicio36"
  1019. // Função :36. Faça um algoritmo que calcule o valor da conta de luz de uma pessoa. Sabe-se que o cálculo da conta de luz segue a tabela abaixo:
  1020.  
  1021. //Tipo de Cliente Valor do KW/h
  1022. //1 (Residência) 0,60
  1023. //2 (Comércio) 0,48
  1024. //3 (Indústria) 1,29
  1025. // Autor : Renan D. Costa
  1026. // Seção de Declarações
  1027.  
  1028. var
  1029.       consumo:real
  1030.       tipo:inteiro
  1031. inicio
  1032. // Seção de Comandos
  1033. escreval("Informe o consumo em kw/h")
  1034. leia(consumo)
  1035. escreval("Informe o tipo de cliente")
  1036. escreval("1-Residencia, 2-Comercio, 3-Industria")
  1037. leia(tipo)
  1038.    escolha(tipo)
  1039.                 caso 1
  1040.                 escreval("O valor da conta eh ",(consumo)*(0.6))
  1041.                 caso 2
  1042.                 escreval("O valor da conta eh ",(consumo)*(0.48))
  1043.                 caso 3
  1044.                 escreval("O valor da conta eh ",(consumo)*(1.29))
  1045.                 outrocaso
  1046.                 escreval("Tipo de cliente invalido")
  1047.                
  1048.    fimescolha
  1049. fimalgoritmo
  1050.  
  1051.  
  1052. algoritmo "exercício37"
  1053. // Função :  37. Faça um algoritmo que leia o nome, o sexo, a altura e a idade de uma pessoa.
  1054. //Calcule e mostre nome e o seu peso ideal de acordo com as seguintes características da pessoa:
  1055.  
  1056.  
  1057. var
  1058.    nome,sexo:literal
  1059.    altura,pesoideal:real
  1060.    idade:inteiro
  1061. inicio
  1062. // Seção de Comandos
  1063. escreval("Informe o nome")
  1064. leia(nome)
  1065. escreval("Informe o sexo: M ou F")
  1066. leia(sexo)
  1067. escreval("informe a altura")
  1068. leia(altura)
  1069. escreval("informe a idade")
  1070. leia(idade)
  1071.             escolha(sexo)
  1072.                       caso "M"
  1073.                          se altura > (1.7) entao
  1074.                               se idade <=20 entao
  1075.                                    pesoideal<-((72.7)*altura)-58
  1076.                               senao
  1077.                                    se (idade >20) e (idade <=39) entao
  1078.                                         pesoideal<-((72.7)*altura)-53
  1079.                                    senao
  1080.                                         pesoideal<-((72.7)*altura)-45
  1081.                                    fimse
  1082.                               fimse
  1083.                          senao
  1084.                               se idade <=40 entao
  1085.                                    pesoideal<-((72.7)*altura)-50
  1086.                               senao
  1087.                                    pesoideal<-((72.7)*altura)-58
  1088.                               fimse
  1089.                          fimse
  1090.                       caso "F"
  1091.                            se altura > 1.5 entao
  1092.                                 pesoideal<-((62.1)*altura)-44.7
  1093.                            senao
  1094.                                 se idade >=35 entao
  1095.                                      pesoideal<-((62.1)*altura)-45
  1096.                                 senao
  1097.                                      pesoideal<-((62.1)*altura)-49
  1098.                                 fimse
  1099.                            fimse
  1100.                       outrocaso
  1101.                       escreval("sexo invalido")
  1102.             fimescolha
  1103.             escreval("O peso ideal de ",nome," eh ",pesoideal)
  1104. fimalgoritmo
  1105.  
  1106. algoritmo "Exercício38"
  1107. // Função : 38. Em um curso de Ciência da Computação a nota do estudante é calculada a partir de três notas atribuídas,
  1108. // respectivamente, a um trabalho de laboratório, a uma avaliação semestral e a um exame final. As notas variam, de 0 a 10 e
  1109. // a nota final é a média ponderada das três notas mencionadas. A tabela abaixo fornece os pesos: (faltou a tabela)
  1110. // Autor : Renan D. Costa
  1111. // Seção de Declarações
  1112.  
  1113. var
  1114. n1,n2,n3:real
  1115. p1,p2,p3:real
  1116. mp:real
  1117. inicio
  1118. // Seção de Comandos
  1119. escreval("Informe a nota do trabalho de laboratório:")
  1120. leia(n1)
  1121. escreval("Informe o peso")
  1122. leia(p1)
  1123. escreval("Informe a nota da avaliação semestral:")
  1124. leia(n2)
  1125. escreval("Informe o peso")
  1126. leia(p2)
  1127. escreval("Informe a nota do exame final:")
  1128. leia(n3)
  1129. escreval("Informe o peso")
  1130. leia(p3)
  1131. mp<-((n1*p1) + (n2*p2)+(n3*p3))/(p1+p2+p3)
  1132. escreval("A media ponderada eh ",mp)
  1133. fimalgoritmo
  1134.  
  1135. algoritmo "Exercício39"
  1136. // Função :39. Dado o nome de um estudante, com o respectivo número de matrícula e as três notas acima mencionadas, desenvolva um algoritmo para calcular a nota final e a classificação de cada estudante. A classificação é dada conforme a tabela abaixo:
  1137.  
  1138. //Nota Final Classificação
  1139. //[8,10] A
  1140. //[7,8] B
  1141. //[6,7] C
  1142. //[5,6] D
  1143. //[0,5] R
  1144. //Imprima o nome do estudante, com o seu número, nota final e classificação.
  1145. // Autor : Renan D. Costa
  1146. // Seção de Declarações
  1147.  
  1148. var
  1149. mat:inteiro
  1150. nome,class:literal
  1151. n1,n2,n3:real
  1152. p1,p2,p3:real
  1153. mp:real
  1154. inicio
  1155. // Seção de Comandos
  1156. p1<-1
  1157. p2<-2
  1158. p3<-3
  1159. //como faltou a tabela de pesos, declarei as variáveis e atribuí valores fictícios pra ela.
  1160. escreval("Informe o nome do aluno:")
  1161. leia(nome)
  1162. escreval("Informe o numero da matricula:")
  1163. leia(mat)
  1164. escreval("Informe a nota do trabalho de laboratorio:")
  1165. leia(n1)
  1166. escreval("Informe o peso")
  1167. leia(p1)
  1168. escreval("Informe a nota da avaliacao semestral:")
  1169. leia(n2)
  1170. escreval("Informe o peso")
  1171. leia(p2)
  1172. escreval("Informe a nota do exame final:")
  1173. leia(n3)
  1174. escreval("Informe o peso")
  1175. leia(p3)
  1176. mp<-((n1*p1) + (n2*p2)+(n3*p3))/(p1+p2+p3)
  1177.              se (mp > 8) entao
  1178.                   class<-"A"
  1179.              senao
  1180.                   se (mp>=7) e (mp<8) entao
  1181.                        class<-"B"
  1182.                   senao
  1183.                        se (mp>=6) e (mp<7) entao
  1184.                             class<-"C"
  1185.                        senao
  1186.                             se (mp>=5) e (mp<6) entao
  1187.                                  class<-"D"
  1188.                             senao
  1189.                                  class<-"R"
  1190.                             fimse
  1191.                        fimse
  1192.                   fimse
  1193.              fimse
  1194. escreval("Aluno: ",nome)
  1195. escreval("Matricula: ",mat)
  1196. escreval("Media: ",mp)
  1197. escreval("Classificacao:", class)
  1198. fimalgoritmo