This week only. Pastebin PRO Accounts Christmas Special! Don't miss out!Want more features on Pastebin? Sign Up, it's FREE!
Guest

BR .config

By: kinsham on Mar 8th, 2013  |  syntax: None  |  size: 33.00 KB  |  views: 43  |  expires: Never
download  |  raw  |  embed  |  report abuse  |  print
Text below is selected. Please press Ctrl+C to copy to your clipboard. (⌘+C on Mac)
  1. #
  2. # Automatically generated make config: don't edit
  3. # Buildroot 2013.05-git-00068-g203c307 Configuration
  4. #
  5. BR2_HAVE_DOT_CONFIG=y
  6. BR2_arm=y
  7. # BR2_armeb is not set
  8. # BR2_aarch64 is not set
  9. # BR2_avr32 is not set
  10. # BR2_bfin is not set
  11. # BR2_i386 is not set
  12. # BR2_microblazeel is not set
  13. # BR2_microblazebe is not set
  14. # BR2_mips is not set
  15. # BR2_mipsel is not set
  16. # BR2_mips64 is not set
  17. # BR2_mips64el is not set
  18. # BR2_powerpc is not set
  19. # BR2_sh is not set
  20. # BR2_sh64 is not set
  21. # BR2_sparc is not set
  22. # BR2_x86_64 is not set
  23. # BR2_xtensa is not set
  24. BR2_ARCH="arm"
  25. BR2_ENDIAN="LITTLE"
  26. BR2_GCC_TARGET_TUNE="xscale"
  27. BR2_GCC_TARGET_ARCH="armv5te"
  28. BR2_GCC_TARGET_ABI="aapcs-linux"
  29. # BR2_generic_arm is not set
  30. # BR2_arm7tdmi is not set
  31. # BR2_arm610 is not set
  32. # BR2_arm710 is not set
  33. # BR2_arm720t is not set
  34. # BR2_arm920t is not set
  35. # BR2_arm922t is not set
  36. # BR2_arm926t is not set
  37. # BR2_arm10t is not set
  38. # BR2_arm1136jf_s_r0 is not set
  39. # BR2_arm1136jf_s_r1 is not set
  40. # BR2_arm1176jz_s is not set
  41. # BR2_arm1176jzf_s is not set
  42. # BR2_cortex_a5 is not set
  43. # BR2_cortex_a8 is not set
  44. # BR2_cortex_a9 is not set
  45. # BR2_cortex_a15 is not set
  46. # BR2_sa110 is not set
  47. # BR2_sa1100 is not set
  48. BR2_xscale=y
  49. # BR2_iwmmxt is not set
  50. # BR2_arm1136jf_s is not set
  51. BR2_ARM_EABI=y
  52.  
  53. #
  54. # Build options
  55. #
  56.  
  57. #
  58. # Commands
  59. #
  60. BR2_WGET="wget --passive-ftp -nd -t 3"
  61. BR2_SVN="svn"
  62. BR2_BZR="bzr"
  63. BR2_GIT="git"
  64. BR2_LOCALFILES="cp"
  65. BR2_SCP="scp"
  66. BR2_SSH="ssh"
  67. BR2_HG="hg"
  68. BR2_ZCAT="gzip -d -c"
  69. BR2_BZCAT="bzcat"
  70. BR2_XZCAT="xzcat"
  71. BR2_TAR_OPTIONS=""
  72. BR2_DEFCONFIG="$(CONFIG_DIR)/defconfig"
  73. BR2_DL_DIR="$(TOPDIR)/dl"
  74. BR2_HOST_DIR="$(BASE_DIR)/host"
  75.  
  76. #
  77. # Mirrors and Download locations
  78. #
  79. BR2_PRIMARY_SITE=""
  80. BR2_BACKUP_SITE="http://sources.buildroot.net/"
  81. BR2_KERNEL_MIRROR="http://www.kernel.org/pub/"
  82. BR2_GNU_MIRROR="http://ftp.gnu.org/pub/gnu"
  83. BR2_DEBIAN_MIRROR="http://ftp.debian.org"
  84. BR2_JLEVEL=0
  85. # BR2_CCACHE is not set
  86. # BR2_DEPRECATED is not set
  87. # BR2_ENABLE_DEBUG is not set
  88. BR2_STRIP_strip=y
  89. # BR2_STRIP_sstrip is not set
  90. # BR2_STRIP_none is not set
  91. BR2_STRIP_EXCLUDE_FILES=""
  92. BR2_STRIP_EXCLUDE_DIRS=""
  93. # BR2_OPTIMIZE_0 is not set
  94. # BR2_OPTIMIZE_1 is not set
  95. # BR2_OPTIMIZE_2 is not set
  96. # BR2_OPTIMIZE_3 is not set
  97. BR2_OPTIMIZE_S=y
  98. # BR2_PREFER_STATIC_LIB is not set
  99. BR2_PACKAGE_OVERRIDE_FILE="$(TOPDIR)/local.mk"
  100.  
  101. #
  102. # Toolchain
  103. #
  104. BR2_TOOLCHAIN_BUILDROOT=y
  105. # BR2_TOOLCHAIN_EXTERNAL is not set
  106. # BR2_TOOLCHAIN_CTNG is not set
  107.  
  108. #
  109. # Kernel Header Options
  110. #
  111. # BR2_KERNEL_HEADERS_3_0 is not set
  112. # BR2_KERNEL_HEADERS_3_2 is not set
  113. # BR2_KERNEL_HEADERS_3_4 is not set
  114. # BR2_KERNEL_HEADERS_3_7 is not set
  115. BR2_KERNEL_HEADERS_3_8=y
  116. # BR2_KERNEL_HEADERS_VERSION is not set
  117. # BR2_KERNEL_HEADERS_SNAP is not set
  118. BR2_DEFAULT_KERNEL_HEADERS="3.8.2"
  119.  
  120. #
  121. # uClibc Options
  122. #
  123. # BR2_UCLIBC_VERSION_0_9_32 is not set
  124. BR2_UCLIBC_VERSION_0_9_33=y
  125. # BR2_UCLIBC_VERSION_SNAPSHOT is not set
  126. BR2_UCLIBC_VERSION_STRING="0.9.33.2"
  127. BR2_UCLIBC_CONFIG="toolchain/uClibc/uClibc-0.9.33.config"
  128. # BR2_PTHREAD_DEBUG is not set
  129. # BR2_UCLIBC_INSTALL_TEST_SUITE is not set
  130. BR2_UCLIBC_ARM_TYPE="ARM_XSCALE"
  131.  
  132. #
  133. # Binutils Options
  134. #
  135. # BR2_BINUTILS_VERSION_2_20_1 is not set
  136. # BR2_BINUTILS_VERSION_2_21 is not set
  137. BR2_BINUTILS_VERSION_2_21_1=y
  138. # BR2_BINUTILS_VERSION_2_22 is not set
  139. # BR2_BINUTILS_VERSION_2_23_1 is not set
  140. BR2_BINUTILS_VERSION="2.21.1"
  141. BR2_BINUTILS_EXTRA_CONFIG_OPTIONS=""
  142.  
  143. #
  144. # GCC Options
  145. #
  146. # BR2_GCC_VERSION_4_3_X is not set
  147. # BR2_GCC_VERSION_4_4_X is not set
  148. # BR2_GCC_VERSION_4_5_X is not set
  149. BR2_GCC_VERSION_4_6_X=y
  150. # BR2_GCC_VERSION_4_7_X is not set
  151. # BR2_GCC_VERSION_SNAP is not set
  152. BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE=y
  153. BR2_GCC_VERSION="4.6.3"
  154. BR2_EXTRA_GCC_CONFIG_OPTIONS=""
  155. # BR2_INSTALL_OBJC is not set
  156. # BR2_INSTALL_FORTRAN is not set
  157. BR2_GCC_SHARED_LIBGCC=y
  158. BR2_GCC_ENABLE_TLS=y
  159. # BR2_GCC_ENABLE_OPENMP is not set
  160.  
  161. #
  162. # Gdb Options
  163. #
  164.  
  165. #
  166. # Gdb for the target needs WCHAR and threads support in toolchain
  167. #
  168. # BR2_PACKAGE_GDB_SERVER is not set
  169. # BR2_PACKAGE_GDB_HOST is not set
  170. BR2_TOOLCHAIN_HAS_THREADS=y
  171. BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED=y
  172. BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS=y
  173. # BR2_ENABLE_LOCALE_PURGE is not set
  174. BR2_GENERATE_LOCALE=""
  175. BR2_NEEDS_GETTEXT=y
  176. BR2_USE_MMU=y
  177. BR2_PREFER_SOFT_FLOAT=y
  178. BR2_SOFT_FLOAT=y
  179. BR2_TARGET_OPTIMIZATION="-pipe"
  180. BR2_TARGET_LDFLAGS=""
  181. # BR2_ECLIPSE_REGISTER is not set
  182.  
  183. #
  184. # Toolchain Options
  185. #
  186. # BR2_TOOLCHAIN_BUILDROOT_LARGEFILE is not set
  187. # BR2_TOOLCHAIN_BUILDROOT_INET_IPV6 is not set
  188. # BR2_TOOLCHAIN_BUILDROOT_INET_RPC is not set
  189. # BR2_TOOLCHAIN_BUILDROOT_WCHAR is not set
  190. # BR2_TOOLCHAIN_BUILDROOT_LOCALE is not set
  191. # BR2_TOOLCHAIN_BUILDROOT_CXX is not set
  192. # BR2_TOOLCHAIN_BUILDROOT_USE_SSP is not set
  193. # BR2_PTHREADS_NONE is not set
  194. # BR2_PTHREADS is not set
  195. # BR2_PTHREADS_OLD is not set
  196. BR2_PTHREADS_NATIVE=y
  197. # BR2_ELF2FLT is not set
  198.  
  199. #
  200. # System configuration
  201. #
  202. BR2_TARGET_GENERIC_HOSTNAME="buildroot"
  203. BR2_TARGET_GENERIC_ISSUE="Welcome to Buildroot"
  204. # BR2_TARGET_GENERIC_PASSWD_DES is not set
  205. BR2_TARGET_GENERIC_PASSWD_MD5=y
  206. # BR2_TARGET_GENERIC_PASSWD_SHA256 is not set
  207. # BR2_TARGET_GENERIC_PASSWD_SHA512 is not set
  208. BR2_TARGET_GENERIC_PASSWD_METHOD="md5"
  209. BR2_ROOTFS_DEVICE_CREATION_STATIC=y
  210. # BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_DEVTMPFS is not set
  211. # BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV is not set
  212.  
  213. #
  214. # udev requires a toolchain with LARGEFILE + WCHAR support
  215. #
  216. BR2_INIT_BUSYBOX=y
  217. # BR2_INIT_SYSV is not set
  218.  
  219. #
  220. # systemd requires largefile, wchar, IPv6, threads and udev support
  221. #
  222. # BR2_INIT_NONE is not set
  223. BR2_ROOTFS_DEVICE_TABLE="system/device_table.txt"
  224. BR2_ROOTFS_STATIC_DEVICE_TABLE="system/device_table_dev.txt"
  225. BR2_ROOTFS_SKELETON_DEFAULT=y
  226. # BR2_ROOTFS_SKELETON_CUSTOM is not set
  227. BR2_TARGET_GENERIC_ROOT_PASSWD=""
  228. BR2_TARGET_GENERIC_GETTY_PORT="ttyS0"
  229. # BR2_TARGET_GENERIC_GETTY_BAUDRATE_KEEP is not set
  230. # BR2_TARGET_GENERIC_GETTY_BAUDRATE_9600 is not set
  231. # BR2_TARGET_GENERIC_GETTY_BAUDRATE_19200 is not set
  232. # BR2_TARGET_GENERIC_GETTY_BAUDRATE_38400 is not set
  233. # BR2_TARGET_GENERIC_GETTY_BAUDRATE_57600 is not set
  234. BR2_TARGET_GENERIC_GETTY_BAUDRATE_115200=y
  235. BR2_TARGET_GENERIC_GETTY_BAUDRATE="115200"
  236. BR2_TARGET_GENERIC_GETTY_TERM="vt100"
  237. BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW=y
  238. BR2_ROOTFS_OVERLAY=""
  239. BR2_ROOTFS_POST_BUILD_SCRIPT=""
  240. BR2_ROOTFS_POST_IMAGE_SCRIPT=""
  241.  
  242. #
  243. # Package Selection for the target
  244. #
  245. BR2_PACKAGE_BUSYBOX=y
  246. # BR2_BUSYBOX_VERSION_1_19_X is not set
  247. # BR2_BUSYBOX_VERSION_1_20_X is not set
  248. BR2_BUSYBOX_VERSION_1_21_X=y
  249. # BR2_PACKAGE_BUSYBOX_SNAPSHOT is not set
  250. BR2_BUSYBOX_VERSION="1.21.0"
  251. BR2_PACKAGE_BUSYBOX_CONFIG="package/busybox/busybox-1.21.x.config"
  252. # BR2_PACKAGE_BUSYBOX_SHOW_OTHERS is not set
  253. # BR2_PACKAGE_BUSYBOX_WATCHDOG is not set
  254.  
  255. #
  256. # Audio and video applications
  257. #
  258.  
  259. #
  260. # alsa-utils requires a toolchain with LARGEFILE and threads support
  261. #
  262. # BR2_PACKAGE_AUMIX is not set
  263.  
  264. #
  265. # bellagio requires a toolchain with C++ support enabled
  266. #
  267. # BR2_PACKAGE_FAAD2 is not set
  268. # BR2_PACKAGE_FLAC is not set
  269.  
  270. #
  271. # ffmpeg requires a toolchain with LARGEFILE and IPV6 support
  272. #
  273.  
  274. #
  275. # gstreamer requires a toolchain with WCHAR support
  276. #
  277.  
  278. #
  279. # gst-ffmpeg requires a toolchain with LARGEFILE and IPV6 support
  280. #
  281. # BR2_PACKAGE_LAME is not set
  282. # BR2_PACKAGE_MADPLAY is not set
  283.  
  284. #
  285. # mpd requires a toolchain with C++ and WCHAR support
  286. #
  287. # BR2_PACKAGE_MPG123 is not set
  288.  
  289. #
  290. # mplayer requires a toolchain with LARGEFILE support
  291. #
  292. # BR2_PACKAGE_MUSEPACK is not set
  293. # BR2_PACKAGE_OPUS_TOOLS is not set
  294.  
  295. #
  296. # pulseaudio requires a toolchain with WCHAR, LARGEFILE and threads support
  297. #
  298. # BR2_PACKAGE_VORBIS_TOOLS is not set
  299. # BR2_PACKAGE_WAVPACK is not set
  300. # BR2_PACKAGE_YAVTA is not set
  301.  
  302. #
  303. # Compressors and decompressors
  304. #
  305. # BR2_PACKAGE_BZIP2 is not set
  306. # BR2_PACKAGE_INFOZIP is not set
  307. # BR2_PACKAGE_LZOP is not set
  308. # BR2_PACKAGE_XZ is not set
  309.  
  310. #
  311. # Debugging, profiling and benchmark
  312. #
  313.  
  314. #
  315. # bonnie++ requires a toolchain with C++ support enabled
  316. #
  317. # BR2_PACKAGE_CACHE_CALIBRATOR is not set
  318. # BR2_PACKAGE_DHRYSTONE is not set
  319.  
  320. #
  321. # dstat requires a toolchain with WCHAR support
  322. #
  323. # BR2_PACKAGE_DMALLOC is not set
  324. # BR2_PACKAGE_KEXEC is not set
  325.  
  326. #
  327. # latencytop requires a toolchain with WCHAR support
  328. #
  329. # BR2_PACKAGE_LMBENCH is not set
  330.  
  331. #
  332. # ltp-testsuite requires a toolchain with IPV6, RPC and thread support
  333. #
  334. # BR2_PACKAGE_LTTNG_MODULES is not set
  335. # BR2_PACKAGE_LTRACE is not set
  336. # BR2_PACKAGE_MEMSTAT is not set
  337. # BR2_PACKAGE_NETPERF is not set
  338.  
  339. #
  340. # oprofile requires a toolchain with C++ support enabled
  341. #
  342.  
  343. #
  344. # perf only available if Linux kernel is enabled, and requires largefile support
  345. #
  346. # BR2_PACKAGE_RAMSPEED is not set
  347. # BR2_PACKAGE_RT_TESTS is not set
  348. # BR2_PACKAGE_STRACE is not set
  349. # BR2_PACKAGE_STRESS is not set
  350.  
  351. #
  352. # sysprof requires a toolchain with WCHAR support
  353. #
  354. # BR2_PACKAGE_WHETSTONE is not set
  355. # BR2_PACKAGE_PV is not set
  356.  
  357. #
  358. # Development tools
  359. #
  360. # BR2_PACKAGE_BINUTILS is not set
  361.  
  362. #
  363. # bison requires a toolchain with WCHAR support
  364. #
  365. # BR2_PACKAGE_BSDIFF is not set
  366.  
  367. #
  368. # bustle requires a toolchain with WCHAR support
  369. #
  370.  
  371. #
  372. # cvs requires a toolchain with WCHAR support
  373. #
  374. # BR2_PACKAGE_DISTCC is not set
  375. # BR2_PACKAGE_FLEX is not set
  376.  
  377. #
  378. # gettext requires a toolchain with WCHAR support
  379. #
  380. # BR2_PACKAGE_GMP is not set
  381.  
  382. #
  383. # gperf requires a toolchain with C++ support enabled
  384. #
  385. # BR2_PACKAGE_MPC is not set
  386. # BR2_PACKAGE_MPFR is not set
  387. # BR2_PACKAGE_LIBTOOL is not set
  388.  
  389. #
  390. # m4 requires a toolchain with WCHAR support
  391. #
  392. # BR2_PACKAGE_PKGCONF is not set
  393. # BR2_PACKAGE_SSTRIP is not set
  394.  
  395. #
  396. # vala requires a toolchain with WCHAR support
  397. #
  398.  
  399. #
  400. # Games
  401. #
  402. # BR2_PACKAGE_GNUCHESS is not set
  403. # BR2_PACKAGE_PRBOOM is not set
  404.  
  405. #
  406. # Graphic libraries and applications (graphic/text)
  407. #
  408.  
  409. #
  410. # Graphic applications
  411. #
  412.  
  413. #
  414. # rrdtool requires a toolchain with WCHAR support
  415. #
  416.  
  417. #
  418. # graphic libraries
  419. #
  420.  
  421. #
  422. # cegui06 needs a toolchain with C++ and threads
  423. #
  424. # BR2_PACKAGE_DIRECTFB is not set
  425. # BR2_PACKAGE_FBDUMP is not set
  426. # BR2_PACKAGE_FBGRAB is not set
  427.  
  428. #
  429. # fbterm requires a toolchain with C++, WCHAR and locale support
  430. #
  431. # BR2_PACKAGE_FBV is not set
  432. # BR2_PACKAGE_FB_TEST_APP is not set
  433. # BR2_PACKAGE_IMAGEMAGICK is not set
  434. # BR2_PACKAGE_LINUX_FUSION is not set
  435. # BR2_PACKAGE_SDL is not set
  436.  
  437. #
  438. # other GUIs
  439. #
  440.  
  441. #
  442. # EFL requires WCHAR support in toolchain
  443. #
  444.  
  445. #
  446. # qt requires a toolchain with C++ support enabled
  447. #
  448.  
  449. #
  450. # X.org requires a toolchain with WCHAR support
  451. #
  452.  
  453. #
  454. # X libraries and helper libraries
  455. #
  456. # BR2_PACKAGE_LIBERATION is not set
  457.  
  458. #
  459. # X Window managers
  460. #
  461.  
  462. #
  463. # X applications
  464. #
  465.  
  466. #
  467. # gob2 requires a toolchain with WCHAR support
  468. #
  469.  
  470. #
  471. # midori requires C++, WCHAR in toolchain and libgtk2
  472. #
  473.  
  474. #
  475. # Filesystem and flash utilities
  476. #
  477. # BR2_PACKAGE_CIFS_UTILS is not set
  478. # BR2_PACKAGE_CRAMFS is not set
  479.  
  480. #
  481. # curlftpfs requires a toolchain with LARGEFILE, WCHAR and threads support
  482. #
  483.  
  484. #
  485. # dosfstools requires a toolchain with LARGEFILE and WCHAR support
  486. #
  487.  
  488. #
  489. # e2fsprogs requires a toolchain with LARGEFILE + WCHAR support
  490. #
  491.  
  492. #
  493. # exfat requires a toolchain with LARGEFILE, WCHAR and threads support
  494. #
  495.  
  496. #
  497. # exfat-utils requires a toolchain with LARGEFILE and WCHAR support
  498. #
  499.  
  500. #
  501. # f2fs-tools requires a toolchain with LARGEFILE and WCHAR support
  502. #
  503.  
  504. #
  505. # flashbench requires a toolchain with LARGEFILE support
  506. #
  507.  
  508. #
  509. # genext2fs requires a toolchain with LARGEFILE support
  510. #
  511. # BR2_PACKAGE_GENROMFS is not set
  512. # BR2_PACKAGE_MAKEDEVS is not set
  513. # BR2_PACKAGE_MTD is not set
  514.  
  515. #
  516. # nfs-utils requires a toolchain with LARGEFILE support
  517. #
  518.  
  519. #
  520. # ntfs-3g requires a toolchain with LARGEFILE and WCHAR support
  521. #
  522.  
  523. #
  524. # squashfs requires a toolchain with LARGEFILE and threads support
  525. #
  526.  
  527. #
  528. # sshfs requires a toolchain with LARGEFILE, WCHAR and threads support
  529. #
  530.  
  531. #
  532. # unionfs requires a toolchain with LARGEFILE and threads support
  533. #
  534.  
  535. #
  536. # xfsprogs requires a toolchain with LARGEFILE + WCHAR support
  537. #
  538.  
  539. #
  540. # Hardware handling
  541. #
  542.  
  543. #
  544. # Misc devices firmwares
  545. #
  546. # BR2_PACKAGE_B43_FIRMWARE is not set
  547. # BR2_PACKAGE_FIRMWARE_IMX is not set
  548. # BR2_PACKAGE_LINUX_FIRMWARE is not set
  549. # BR2_PACKAGE_RPI_FIRMWARE is not set
  550. # BR2_PACKAGE_UX500_FIRMWARE is not set
  551. # BR2_PACKAGE_ZD1211_FIRMWARE is not set
  552.  
  553. #
  554. # cdrkit requires a toolchain with LARGEFILE support
  555. #
  556. # BR2_PACKAGE_DBUS is not set
  557.  
  558. #
  559. # dmraid requires a toolchain with LARGEFILE support
  560. #
  561. # BR2_PACKAGE_DVB_APPS is not set
  562.  
  563. #
  564. # dvbsnoop requires a toolchain with LARGEFILE support
  565. #
  566. # BR2_PACKAGE_EEPROG is not set
  567. # BR2_PACKAGE_EVTEST is not set
  568. BR2_PACKAGE_FCONFIG=y
  569. BR2_PACKAGE_FIS=y
  570. # BR2_PACKAGE_FMTOOLS is not set
  571. # BR2_PACKAGE_FXLOAD is not set
  572. # BR2_PACKAGE_GADGETFS_TEST is not set
  573.  
  574. #
  575. # gdisk requires a toolchain with LARGEFILE/WCHAR/C++ support enabled
  576. #
  577. # BR2_PACKAGE_GPSD is not set
  578.  
  579. #
  580. # gvfs requires a toolchain with LARGEFILE and WCHAR support
  581. #
  582. # BR2_PACKAGE_HWDATA is not set
  583. # BR2_PACKAGE_I2C_TOOLS is not set
  584. # BR2_PACKAGE_INPUT_EVENT_DAEMON is not set
  585. # BR2_PACKAGE_INPUT_TOOLS is not set
  586. # BR2_PACKAGE_IOSTAT is not set
  587. # BR2_PACKAGE_IRDA_UTILS is not set
  588. # BR2_PACKAGE_KBD is not set
  589. # BR2_PACKAGE_LCDPROC is not set
  590. # BR2_PACKAGE_LM_SENSORS is not set
  591.  
  592. #
  593. # lshw requires a toolchain with C++, LARGEFILE & WCHAR support enabled
  594. #
  595. # BR2_PACKAGE_LSUIO is not set
  596.  
  597. #
  598. # lvm2 requires a toolchain with LARGEFILE support
  599. #
  600. # BR2_PACKAGE_MDADM is not set
  601. # BR2_PACKAGE_MEDIA_CTL is not set
  602.  
  603. #
  604. # memtester requires a toolchain with LARGEFILE support
  605. #
  606.  
  607. #
  608. # minicom requires a toolchain with WCHAR support
  609. #
  610. # BR2_PACKAGE_NANOCOM is not set
  611.  
  612. #
  613. # neard requires a toolchain with WCHAR and threads support
  614. #
  615.  
  616. #
  617. # ofono requires a toolchain with WCHAR and thread support
  618. #
  619. # BR2_PACKAGE_OPEN2300 is not set
  620. # BR2_PACKAGE_OPENOCD is not set
  621.  
  622. #
  623. # owl-linux is only supported on ARM9 architecture with EABI
  624. #
  625.  
  626. #
  627. # parted requires a toolchain with LARGEFILE+WCHAR support
  628. #
  629. # BR2_PACKAGE_PCIUTILS is not set
  630. # BR2_PACKAGE_PICOCOM is not set
  631. # BR2_PACKAGE_RNG_TOOLS is not set
  632.  
  633. #
  634. # rpi-userland requires a toolchain with C++ and LARGEFILE support
  635. #
  636. # BR2_PACKAGE_SANE_BACKENDS is not set
  637. # BR2_PACKAGE_SDPARM is not set
  638. # BR2_PACKAGE_SETSERIAL is not set
  639.  
  640. #
  641. # sg3-utils requires a toolchain with LARGEFILE and threads support
  642. #
  643.  
  644. #
  645. # smartmontools requires a toolchain with C++ support enabled
  646. #
  647. # BR2_PACKAGE_SNOWBALL_HDMISERVICE is not set
  648. # BR2_PACKAGE_SREDIRD is not set
  649. # BR2_PACKAGE_STATSERIAL is not set
  650. # BR2_PACKAGE_SYSSTAT is not set
  651. # BR2_PACKAGE_TI_UTILS is not set
  652. # BR2_PACKAGE_UBOOT_TOOLS is not set
  653.  
  654. #
  655. # udev requires /dev mgmnt set to udev under System configuration
  656. #
  657.  
  658. #
  659. # udisks requires /dev mgmnt set to udev under System configuration
  660. #
  661. # BR2_PACKAGE_USB_MODESWITCH is not set
  662. # BR2_PACKAGE_USB_MODESWITCH_DATA is not set
  663. # BR2_PACKAGE_USBUTILS is not set
  664. # BR2_PACKAGE_WIPE is not set
  665.  
  666. #
  667. # Interpreter languages and scripting
  668. #
  669. # BR2_PACKAGE_ERLANG is not set
  670. # BR2_PACKAGE_HASERL is not set
  671.  
  672. #
  673. # jamvm requires a toolchain with IPV6 support
  674. #
  675. # BR2_PACKAGE_LUA is not set
  676. # BR2_PACKAGE_LUAJIT is not set
  677. # BR2_PACKAGE_PERL is not set
  678. # BR2_PACKAGE_PHP is not set
  679.  
  680. #
  681. # python requires a toolchain with WCHAR support
  682. #
  683.  
  684. #
  685. # python3 requires a toolchain with WCHAR support
  686. #
  687.  
  688. #
  689. # ruby requires a toolchain with WCHAR support
  690. #
  691. # BR2_PACKAGE_TCL is not set
  692.  
  693. #
  694. # Libraries
  695. #
  696.  
  697. #
  698. # Audio/Sound
  699. #
  700. # BR2_PACKAGE_ALSA_LIB is not set
  701.  
  702. #
  703. # audiofile requires a toolchain with C++ support enabled
  704. #
  705. # BR2_PACKAGE_CELT051 is not set
  706. # BR2_PACKAGE_LIBAO is not set
  707. # BR2_PACKAGE_LIBCDAUDIO is not set
  708. # BR2_PACKAGE_LIBCUE is not set
  709. # BR2_PACKAGE_LIBCUEFILE is not set
  710. # BR2_PACKAGE_LIBID3TAG is not set
  711. # BR2_PACKAGE_LIBLO is not set
  712. # BR2_PACKAGE_LIBMAD is not set
  713.  
  714. #
  715. # libmpd requires a toolchain with WCHAR support
  716. #
  717. # BR2_PACKAGE_LIBREPLAYGAIN is not set
  718. # BR2_PACKAGE_LIBSAMPLERATE is not set
  719.  
  720. #
  721. # libsndfile requires a toolchain with LARGEFILE support
  722. #
  723. # BR2_PACKAGE_LIBVORBIS is not set
  724. # BR2_PACKAGE_OPUS is not set
  725. # BR2_PACKAGE_PORTAUDIO is not set
  726. # BR2_PACKAGE_SPEEX is not set
  727.  
  728. #
  729. # taglib requires a toolchain with C++ support enabled
  730. #
  731. # BR2_PACKAGE_TREMOR is not set
  732.  
  733. #
  734. # webrtc-audio-processing requires a toolchain with C++ support enabled
  735. #
  736.  
  737. #
  738. # Compression and decompression
  739. #
  740.  
  741. #
  742. # libarchive requires a toolchain with WCHAR support
  743. #
  744. # BR2_PACKAGE_LZO is not set
  745. # BR2_PACKAGE_ZLIB is not set
  746.  
  747. #
  748. # Crypto
  749. #
  750. # BR2_PACKAGE_BEECRYPT is not set
  751.  
  752. #
  753. # gnutls requires a toolchain with WCHAR support
  754. #
  755. # BR2_PACKAGE_LIBGCRYPT is not set
  756. # BR2_PACKAGE_LIBGPG_ERROR is not set
  757. # BR2_PACKAGE_LIBMCRYPT is not set
  758. # BR2_PACKAGE_LIBMHASH is not set
  759. # BR2_PACKAGE_LIBSHA1 is not set
  760. # BR2_PACKAGE_NETTLE is not set
  761. # BR2_PACKAGE_OCF_LINUX is not set
  762. # BR2_PACKAGE_OPENSSL is not set
  763. # BR2_PACKAGE_POLARSSL is not set
  764.  
  765. #
  766. # Database
  767. #
  768. # BR2_PACKAGE_BERKELEYDB is not set
  769. # BR2_PACKAGE_GDBM is not set
  770.  
  771. #
  772. # Mysql client requires a toolchain with C++ support enabled
  773. #
  774. # BR2_PACKAGE_SQLCIPHER is not set
  775. # BR2_PACKAGE_SQLITE is not set
  776.  
  777. #
  778. # Filesystem
  779. #
  780.  
  781. #
  782. # gamin requires a toolchain with WCHAR support
  783. #
  784. # BR2_PACKAGE_LIBCONFIG is not set
  785. # BR2_PACKAGE_LIBCONFUSE is not set
  786.  
  787. #
  788. # libfuse requires a toolchain with LARGEFILE and threads support
  789. #
  790. # BR2_PACKAGE_LIBLOCKFILE is not set
  791. # BR2_PACKAGE_LIBSYSFS is not set
  792.  
  793. #
  794. # Graphics
  795. #
  796.  
  797. #
  798. # atk requires a toolchain with WCHAR support
  799. #
  800. # BR2_PACKAGE_CAIRO is not set
  801. # BR2_PACKAGE_FONTCONFIG is not set
  802. # BR2_PACKAGE_FREETYPE is not set
  803. # BR2_PACKAGE_GD is not set
  804. # BR2_PACKAGE_IMLIB2 is not set
  805. # BR2_PACKAGE_JPEG is not set
  806. # BR2_PACKAGE_LIBART is not set
  807. # BR2_PACKAGE_LIBDMTX is not set
  808. # BR2_PACKAGE_LIBEXIF is not set
  809. # BR2_PACKAGE_LIBGEOTIFF is not set
  810.  
  811. #
  812. # libgtk2 requires a toolchain with WCHAR and C++ support
  813. #
  814. # BR2_PACKAGE_LIBPNG is not set
  815.  
  816. #
  817. # libraw requires a toolchain with C++ support enabled
  818. #
  819.  
  820. #
  821. # librsvg requires a toolchain with WCHAR and C++ support
  822. #
  823. # BR2_PACKAGE_LIBSVGTINY is not set
  824. # BR2_PACKAGE_LIBUNGIF is not set
  825.  
  826. #
  827. # opencv requires a toolchain with C++ and WCHAR support
  828. #
  829.  
  830. #
  831. # pango requires a toolchain with WCHAR and C++ support
  832. #
  833. # BR2_PACKAGE_PIXMAN is not set
  834. # BR2_PACKAGE_TIFF is not set
  835.  
  836. #
  837. # webkit requires C++, WCHAR in toolchain and libgtk2
  838. #
  839.  
  840. #
  841. # zxing requires a toolchain with C++ support
  842. #
  843.  
  844. #
  845. # Hardware handling
  846. #
  847. # BR2_PACKAGE_CCID is not set
  848. # BR2_PACKAGE_IMX_LIB is not set
  849.  
  850. #
  851. # lcdapi requires a toolchain with C++ and thread support enabled
  852. #
  853. # BR2_PACKAGE_LIBAIO is not set
  854.  
  855. #
  856. # libatasmart requires udev to be enabled
  857. #
  858. # BR2_PACKAGE_LIBRAW1394 is not set
  859. # BR2_PACKAGE_TSLIB is not set
  860. # BR2_PACKAGE_LIBFREEFARE is not set
  861. # BR2_PACKAGE_LIBFTDI is not set
  862. # BR2_PACKAGE_LIBHID is not set
  863. # BR2_PACKAGE_LIBIQRF is not set
  864. # BR2_PACKAGE_LIBNFC is not set
  865. # BR2_PACKAGE_LIBNFC_LLCP is not set
  866. # BR2_PACKAGE_LIBUSB is not set
  867.  
  868. #
  869. # libv4l requires a toolchain with LARGEFILE support
  870. #
  871. # BR2_PACKAGE_MTDEV is not set
  872.  
  873. #
  874. # neardal requires a toolchain with WCHAR and threads support
  875. #
  876. # BR2_PACKAGE_PCSC_LITE is not set
  877.  
  878. #
  879. # Javascript
  880. #
  881. # BR2_PACKAGE_EXPLORERCANVAS is not set
  882. # BR2_PACKAGE_FLOT is not set
  883. # BR2_PACKAGE_JQUERY is not set
  884. # BR2_PACKAGE_JQUERY_SPARKLINE is not set
  885. # BR2_PACKAGE_JQUERY_VALIDATION is not set
  886. # BR2_PACKAGE_JSMIN is not set
  887.  
  888. #
  889. # Multimedia
  890. #
  891.  
  892. #
  893. # libdvdread requires a toolchain with LARGEFILE support
  894. #
  895.  
  896. #
  897. # libdvdnav requires a toolchain with LARGEFILE and thread support
  898. #
  899.  
  900. #
  901. # libebml requires a toolchain with C++ support
  902. #
  903. # BR2_PACKAGE_LIBFSLCODEC is not set
  904. # BR2_PACKAGE_LIBFSLPARSER is not set
  905. # BR2_PACKAGE_LIBFSLVPUWRAP is not set
  906.  
  907. #
  908. # libmatroska requires a toolchain with C++ support
  909. #
  910.  
  911. #
  912. # libmms requires a toolchain with WCHAR support
  913. #
  914. # BR2_PACKAGE_LIBMPEG2 is not set
  915. # BR2_PACKAGE_LIBOGG is not set
  916.  
  917. #
  918. # libplayer requires a toolchain with LARGEFILE support
  919. #
  920. # BR2_PACKAGE_LIBTHEORA is not set
  921.  
  922. #
  923. # Live555 needs C++ compiler
  924. #
  925.  
  926. #
  927. # mediastreamer requires a toolchain with threads and C++ support
  928. #
  929.  
  930. #
  931. # Networking
  932. #
  933.  
  934. #
  935. # glib-networking requires a toolchain with WCHAR support
  936. #
  937. # BR2_PACKAGE_LIBCGI is not set
  938.  
  939. #
  940. # libcgicc requires a toolchain with C++ support enabled
  941. #
  942. # BR2_PACKAGE_LIBCURL is not set
  943. # BR2_PACKAGE_LIBDNET is not set
  944. # BR2_PACKAGE_LIBESMTP is not set
  945. # BR2_PACKAGE_LIBEXOSIP2 is not set
  946. # BR2_PACKAGE_LIBFCGI is not set
  947. # BR2_PACKAGE_LIBGSASL is not set
  948. # BR2_PACKAGE_LIBIDN is not set
  949. # BR2_PACKAGE_LIBISCSI is not set
  950. # BR2_PACKAGE_LIBOAUTH is not set
  951. # BR2_PACKAGE_LIBMICROHTTPD is not set
  952. # BR2_PACKAGE_NEON is not set
  953.  
  954. #
  955. # libmnl requires a toolchain with LARGEFILE support
  956. #
  957. # BR2_PACKAGE_LIBMODBUS is not set
  958. # BR2_PACKAGE_LIBMBUS is not set
  959.  
  960. #
  961. # libnetfilter_acct requires a toolchain with LARGEFILE support
  962. #
  963.  
  964. #
  965. # libnetfilter_conntrack requires a toolchain with LARGEFILE support
  966. #
  967.  
  968. #
  969. # libnetfilter_cthelper requires a toolchain with LARGEFILE support
  970. #
  971.  
  972. #
  973. # libnetfilter_cttimout requires a toolchain with LARGEFILE support
  974. #
  975. # BR2_PACKAGE_LIBNETFILTER_LOG is not set
  976.  
  977. #
  978. # libnetfilter_queue requires a toolchain with LARGEFILE and IPv6 support
  979. #
  980. # BR2_PACKAGE_LIBNFNETLINK is not set
  981. # BR2_PACKAGE_LIBNL is not set
  982.  
  983. #
  984. # liboping requires a toolchain with IPv6 support enabled
  985. #
  986. # BR2_PACKAGE_LIBPCAP is not set
  987. # BR2_PACKAGE_LIBOSIP2 is not set
  988. # BR2_PACKAGE_LIBRSYNC is not set
  989.  
  990. #
  991. # libsoup requires a toolchain with WCHAR support
  992. #
  993. # BR2_PACKAGE_LIBTIRPC is not set
  994.  
  995. #
  996. # libtorrent requires a toolchain with C++ and threads support enabled
  997. #
  998.  
  999. #
  1000. # libupnp requires a toolchain with LARGEFILE and thread support
  1001. #
  1002. # BR2_PACKAGE_LIBVNCSERVER is not set
  1003. # BR2_PACKAGE_ORTP is not set
  1004. # BR2_PACKAGE_SLIRP is not set
  1005. # BR2_PACKAGE_USBREDIR is not set
  1006.  
  1007. #
  1008. # zeromq requires a toolchain with C++, LARGEFILE + WCHAR support
  1009. #
  1010.  
  1011. #
  1012. # Other
  1013. #
  1014. # BR2_PACKAGE_APR is not set
  1015. # BR2_PACKAGE_APR_UTIL is not set
  1016. # BR2_PACKAGE_LIBCOFI is not set
  1017.  
  1018. #
  1019. # classpath requires a toolchain with IPV6 support
  1020. #
  1021.  
  1022. #
  1023. # elfutils requires a toolchain with LARGEFILE and WCHAR support
  1024. #
  1025. # BR2_PACKAGE_FFTW is not set
  1026. # BR2_PACKAGE_LIBARGTABLE2 is not set
  1027. # BR2_PACKAGE_ARGP_STANDALONE is not set
  1028.  
  1029. #
  1030. # boost requires a toolchain with C++, large file and thread support enabled
  1031. #
  1032. # BR2_PACKAGE_LIBATOMIC_OPS is not set
  1033. # BR2_PACKAGE_LIBCAP is not set
  1034. # BR2_PACKAGE_LIBCAP_NG is not set
  1035. # BR2_PACKAGE_LIBDAEMON is not set
  1036. # BR2_PACKAGE_LIBELF is not set
  1037. # BR2_PACKAGE_LIBEVENT is not set
  1038. # BR2_PACKAGE_LIBEV is not set
  1039. # BR2_PACKAGE_LIBFFI is not set
  1040. # BR2_PACKAGE_GSL is not set
  1041.  
  1042. #
  1043. # libglib2 requires a toolchain with WCHAR support
  1044. #
  1045.  
  1046. #
  1047. # libical requires a toolchain with WCHAR support
  1048. #
  1049.  
  1050. #
  1051. # libsigc++ requires a toolchain with C++ support enabled
  1052. #
  1053. # BR2_PACKAGE_LIBTASN1 is not set
  1054. # BR2_PACKAGE_LIBTPL is not set
  1055. # BR2_PACKAGE_LIBURCU is not set
  1056.  
  1057. #
  1058. # linux-pam requires a toolchain with WCHAR and locale support
  1059. #
  1060. # BR2_PACKAGE_MTDEV2TUIO is not set
  1061. # BR2_PACKAGE_ORC is not set
  1062.  
  1063. #
  1064. # poco requires a toolchain with WCHAR and C++ support
  1065. #
  1066.  
  1067. #
  1068. # protobuf requires a toolchain with C++ support enabled
  1069. #
  1070.  
  1071. #
  1072. # schifra requires a toolchain with C++ support enabled
  1073. #
  1074. # BR2_PACKAGE_LIBLOG4C_LOCALTIME is not set
  1075.  
  1076. #
  1077. # Text and terminal handling
  1078. #
  1079.  
  1080. #
  1081. # enchant requires a toolchain with C++ and WCHAR support enabled
  1082. #
  1083. # BR2_PACKAGE_LIBFRIBIDI is not set
  1084.  
  1085. #
  1086. # icu requires a toolchain with C++ support and WCHAR enabled
  1087. #
  1088. # BR2_PACKAGE_LIBICONV is not set
  1089. # BR2_PACKAGE_LINENOISE is not set
  1090. BR2_PACKAGE_NCURSES=y
  1091. # BR2_PACKAGE_NCURSES_TARGET_PANEL is not set
  1092. # BR2_PACKAGE_NCURSES_TARGET_FORM is not set
  1093. # BR2_PACKAGE_NCURSES_TARGET_MENU is not set
  1094. # BR2_PACKAGE_NEWT is not set
  1095. # BR2_PACKAGE_PCRE is not set
  1096. # BR2_PACKAGE_POPT is not set
  1097. # BR2_PACKAGE_READLINE is not set
  1098. # BR2_PACKAGE_SLANG is not set
  1099.  
  1100. #
  1101. # JSON/XML
  1102. #
  1103. # BR2_PACKAGE_CJSON is not set
  1104. # BR2_PACKAGE_EXPAT is not set
  1105. # BR2_PACKAGE_EZXML is not set
  1106. # BR2_PACKAGE_JSON_C is not set
  1107. # BR2_PACKAGE_LIBROXML is not set
  1108. # BR2_PACKAGE_LIBXML2 is not set
  1109. # BR2_PACKAGE_LIBXSLT is not set
  1110. # BR2_PACKAGE_LIBYAML is not set
  1111. # BR2_PACKAGE_MXML is not set
  1112.  
  1113. #
  1114. # xerces-c++ requires a toolchain with C++ and WCHAR support enabled
  1115. #
  1116. # BR2_PACKAGE_YAJL is not set
  1117.  
  1118. #
  1119. # Miscellaneous
  1120. #
  1121. # BR2_PACKAGE_COLLECTD is not set
  1122. # BR2_PACKAGE_EMPTY is not set
  1123. # BR2_PACKAGE_GOOGLEFONTDIRECTORY is not set
  1124. # BR2_PACKAGE_MCRYPT is not set
  1125. # BR2_PACKAGE_MOBILE_BROADBAND_PROVIDER_INFO is not set
  1126.  
  1127. #
  1128. # shared-mime-info requires a toolchain with WCHAR support
  1129. #
  1130. # BR2_PACKAGE_SOUND_THEME_BOREALIS is not set
  1131. # BR2_PACKAGE_SOUND_THEME_FREEDESKTOP is not set
  1132.  
  1133. #
  1134. # Networking applications
  1135. #
  1136.  
  1137. #
  1138. # aircrack-ng needs a toolchain with largefile support
  1139. #
  1140. # BR2_PACKAGE_ARGUS is not set
  1141. # BR2_PACKAGE_ARPTABLES is not set
  1142. # BR2_PACKAGE_AVAHI is not set
  1143. # BR2_PACKAGE_AXEL is not set
  1144.  
  1145. #
  1146. # bluez-utils require a toolchain with WCHAR and thread support
  1147. #
  1148. # BR2_PACKAGE_BOA is not set
  1149.  
  1150. #
  1151. # bind requires a toolchain with LARGEFILE and IPV6 support
  1152. #
  1153.  
  1154. #
  1155. # bmon requires a toolchain with IPv6 support
  1156. #
  1157. # BR2_PACKAGE_BRIDGE_UTILS is not set
  1158. # BR2_PACKAGE_CAN_UTILS is not set
  1159.  
  1160. #
  1161. # connman needs a toolchain with IPv6, WCHAR, thread and resolver support
  1162. #
  1163.  
  1164. #
  1165. # ctorrent requires a toolchain with C++ support enabled
  1166. #
  1167.  
  1168. #
  1169. # conntrack-tools requires a toolchain with IPV6 and LARGEFILE support
  1170. #
  1171. # BR2_PACKAGE_CUPS is not set
  1172. # BR2_PACKAGE_DHCPDUMP is not set
  1173. # BR2_PACKAGE_DNSMASQ is not set
  1174. # BR2_PACKAGE_DROPBEAR is not set
  1175.  
  1176. #
  1177. # ebtables requires a toolchain with IPv6 support
  1178. #
  1179. # BR2_PACKAGE_ETHTOOL is not set
  1180.  
  1181. #
  1182. # gesftpserver requires a toolchain with WCHAR and threads support
  1183. #
  1184. # BR2_PACKAGE_HEIRLOOM_MAILX is not set
  1185. # BR2_PACKAGE_HIAWATHA is not set
  1186. # BR2_PACKAGE_HOSTAPD is not set
  1187. # BR2_PACKAGE_HTTPING is not set
  1188.  
  1189. #
  1190. # iftop requires IPv6 and threads support in toolchain
  1191. #
  1192. # BR2_PACKAGE_IGH_ETHERCAT is not set
  1193. # BR2_PACKAGE_INADYN is not set
  1194.  
  1195. #
  1196. # iperf requires a toolchain with C++ support enabled
  1197. #
  1198. # BR2_PACKAGE_IPROUTE2 is not set
  1199. # BR2_PACKAGE_IPSEC_TOOLS is not set
  1200.  
  1201. #
  1202. # ipset requires a toolchain with LARGEFILE support
  1203. #
  1204. # BR2_PACKAGE_IPTABLES is not set
  1205. # BR2_PACKAGE_IW is not set
  1206.  
  1207. #
  1208. # Kismet requires a toolchain with C++ support enabled
  1209. #
  1210. # BR2_PACKAGE_LIGHTTPD is not set
  1211. # BR2_PACKAGE_LINKS is not set
  1212.  
  1213. #
  1214. # linphone requires a toolchain with threads and C++ support enabled
  1215. #
  1216. # BR2_PACKAGE_LRZSZ is not set
  1217. # BR2_PACKAGE_MACCHANGER is not set
  1218. # BR2_PACKAGE_MII_DIAG is not set
  1219. # BR2_PACKAGE_MROUTED is not set
  1220. # BR2_PACKAGE_MSMTP is not set
  1221.  
  1222. #
  1223. # mutt requires a toolchain with WCHAR support
  1224. #
  1225.  
  1226. #
  1227. # nbd requires a toolchain with WCHAR support
  1228. #
  1229. # BR2_PACKAGE_NCFTP is not set
  1230.  
  1231. #
  1232. # ndisc6 requires a toolchain with IPv6 support
  1233. #
  1234. # BR2_PACKAGE_NETATALK is not set
  1235. # BR2_PACKAGE_NETPLUG is not set
  1236. # BR2_PACKAGE_NETSNMP is not set
  1237. # BR2_PACKAGE_NETSTAT_NAT is not set
  1238.  
  1239. #
  1240. # NetworkManager requires a toolchain with IPV6, LARGEFILE, WCHAR and thread support
  1241. #
  1242.  
  1243. #
  1244. # nfacct requires a toolchain with LARGEFILE support
  1245. #
  1246.  
  1247. #
  1248. # nmap requires a toolchain with C++, IPV6 and thread support
  1249. #
  1250. # BR2_PACKAGE_NOIP is not set
  1251. # BR2_PACKAGE_NGIRCD is not set
  1252. # BR2_PACKAGE_NGREP is not set
  1253. # BR2_PACKAGE_NTP is not set
  1254. # BR2_PACKAGE_NUTTCP is not set
  1255.  
  1256. #
  1257. # olsr requires a toolchain with IPv6 and threads support
  1258. #
  1259. # BR2_PACKAGE_OPENNTPD is not set
  1260. # BR2_PACKAGE_OPENSSH is not set
  1261. # BR2_PACKAGE_OPENSWAN is not set
  1262.  
  1263. #
  1264. # openvpn requires a toolchain with IPV6 support
  1265. #
  1266.  
  1267. #
  1268. # portmap requires a toolchain with RPC support
  1269. #
  1270. # BR2_PACKAGE_PPPD is not set
  1271. # BR2_PACKAGE_PPTP_LINUX is not set
  1272. # BR2_PACKAGE_PROFTPD is not set
  1273. # BR2_PACKAGE_PROXYCHAINS_NG is not set
  1274. # BR2_PACKAGE_QUAGGA is not set
  1275.  
  1276. #
  1277. # radvd requires a toolchain with IPV6 support
  1278. #
  1279. # BR2_PACKAGE_RPCBIND is not set
  1280. # BR2_PACKAGE_RSH_REDONE is not set
  1281. # BR2_PACKAGE_RSYNC is not set
  1282.  
  1283. #
  1284. # rtorrent requires a toolchain with C++, threads and WCHAR support
  1285. #
  1286. # BR2_PACKAGE_SAMBA is not set
  1287.  
  1288. #
  1289. # sconeserver requires a toolchain with C++ support enabled
  1290. #
  1291. # BR2_PACKAGE_SER2NET is not set
  1292. # BR2_PACKAGE_SOCAT is not set
  1293. # BR2_PACKAGE_SOCKETCAND is not set
  1294. # BR2_PACKAGE_SPAWN_FCGI is not set
  1295. # BR2_PACKAGE_SPICE_PROTOCOL is not set
  1296.  
  1297. #
  1298. # Squid requires a toolchain with C++ and IPv6 support enabled
  1299. #
  1300. # BR2_PACKAGE_STUNNEL is not set
  1301. # BR2_PACKAGE_TCPDUMP is not set
  1302. # BR2_PACKAGE_TCPREPLAY is not set
  1303. # BR2_PACKAGE_THTTPD is not set
  1304. # BR2_PACKAGE_TINYHTTPD is not set
  1305. # BR2_PACKAGE_TN5250 is not set
  1306.  
  1307. #
  1308. # Transmission requires a toolchain with IPv6 and threads support
  1309. #
  1310.  
  1311. #
  1312. # tvheadend requires a toolchain with LARGEFILE and IPv6 support
  1313. #
  1314.  
  1315. #
  1316. # udpcast requires a toolchain with LARGEFILE support
  1317. #
  1318.  
  1319. #
  1320. # ulogd requires a toolchain with IPV6 and LARGEFILE support
  1321. #
  1322.  
  1323. #
  1324. # ushare requires a toolchain with LARGEFILE and thread support
  1325. #
  1326. # BR2_PACKAGE_VDE2 is not set
  1327. # BR2_PACKAGE_VPNC is not set
  1328. # BR2_PACKAGE_VSFTPD is not set
  1329. # BR2_PACKAGE_VTUN is not set
  1330. # BR2_PACKAGE_WIRELESS_TOOLS is not set
  1331.  
  1332. #
  1333. # wireshark requires a toolchain with WCHAR support
  1334. #
  1335. # BR2_PACKAGE_WPA_SUPPLICANT is not set
  1336. # BR2_PACKAGE_XINETD is not set
  1337. # BR2_PACKAGE_XL2TP is not set
  1338.  
  1339. #
  1340. # Package managers
  1341. #
  1342. # BR2_PACKAGE_IPKG is not set
  1343. # BR2_PACKAGE_OPKG is not set
  1344.  
  1345. #
  1346. # Real-Time
  1347. #
  1348. # BR2_PACKAGE_XENOMAI is not set
  1349.  
  1350. #
  1351. # Shell and utilities
  1352. #
  1353. # BR2_PACKAGE_AT is not set
  1354. # BR2_PACKAGE_DIALOG is not set
  1355. # BR2_PACKAGE_FILE is not set
  1356. # BR2_PACKAGE_GNUPG is not set
  1357.  
  1358. #
  1359. # inotify-tools requires a toolchain with LARGEFILE support
  1360. #
  1361. # BR2_PACKAGE_LOCKFILE_PROGS is not set
  1362.  
  1363. #
  1364. # logrotate requires a toolchain with WCHAR support
  1365. #
  1366. # BR2_PACKAGE_LOGSURFER is not set
  1367. # BR2_PACKAGE_SCREEN is not set
  1368. # BR2_PACKAGE_SUDO is not set
  1369. # BR2_PACKAGE_XMLSTARLET is not set
  1370.  
  1371. #
  1372. # System tools
  1373. #
  1374.  
  1375. #
  1376. # acl requires a toolchain with LARGEFILE support
  1377. #
  1378.  
  1379. #
  1380. # attr requires a toolchain with LARGEFILE support
  1381. #
  1382. # BR2_PACKAGE_BWM_NG is not set
  1383. # BR2_PACKAGE_CPULOAD is not set
  1384. # BR2_PACKAGE_HTOP is not set
  1385. # BR2_PACKAGE_KEYUTILS is not set
  1386. # BR2_PACKAGE_KMOD is not set
  1387. # BR2_PACKAGE_MONIT is not set
  1388. # BR2_PACKAGE_NCDU is not set
  1389.  
  1390. #
  1391. # polkit requires a toolchain with WCHAR support
  1392. #
  1393.  
  1394. #
  1395. # quota requires a toolchain with LARGEFILE + WCHAR support
  1396. #
  1397.  
  1398. #
  1399. # supervisor needs the python interpreter
  1400. #
  1401.  
  1402. #
  1403. # systemd not available (depends on /dev management with udev and ipv6 support, and thread support in toolchain)
  1404. #
  1405.  
  1406. #
  1407. # util-linux requires a toolchain with LARGEFILE + WCHAR support
  1408. #
  1409.  
  1410. #
  1411. # Text editors and viewers
  1412. #
  1413. # BR2_PACKAGE_ED is not set
  1414. BR2_PACKAGE_NANO=y
  1415. BR2_PACKAGE_NANO_TINY=y
  1416. # BR2_PACKAGE_UEMACS is not set
  1417.  
  1418. #
  1419. # Host utilities
  1420. #
  1421. # BR2_PACKAGE_HOST_DFU_UTIL is not set
  1422. # BR2_PACKAGE_HOST_LPC3250LOADER is not set
  1423. # BR2_PACKAGE_HOST_OMAP_U_BOOT_UTILS is not set
  1424. # BR2_PACKAGE_HOST_OPENOCD is not set
  1425. # BR2_PACKAGE_HOST_SAM_BA is not set
  1426. # BR2_PACKAGE_HOST_UBOOT_TOOLS is not set
  1427.  
  1428. #
  1429. # Filesystem images
  1430. #
  1431. # BR2_TARGET_ROOTFS_CLOOP is not set
  1432. # BR2_TARGET_ROOTFS_CPIO is not set
  1433. # BR2_TARGET_ROOTFS_CPIO_NONE is not set
  1434. # BR2_TARGET_ROOTFS_CPIO_GZIP is not set
  1435. # BR2_TARGET_ROOTFS_CPIO_BZIP2 is not set
  1436. # BR2_TARGET_ROOTFS_CPIO_LZMA is not set
  1437. # BR2_TARGET_ROOTFS_CRAMFS is not set
  1438. # BR2_TARGET_ROOTFS_EXT2 is not set
  1439. # BR2_TARGET_ROOTFS_INITRAMFS is not set
  1440. # BR2_TARGET_ROOTFS_JFFS2 is not set
  1441. # BR2_TARGET_ROOTFS_ROMFS is not set
  1442. # BR2_TARGET_ROOTFS_SQUASHFS is not set
  1443. BR2_TARGET_ROOTFS_TAR=y
  1444. # BR2_TARGET_ROOTFS_TAR_NONE is not set
  1445. BR2_TARGET_ROOTFS_TAR_GZIP=y
  1446. # BR2_TARGET_ROOTFS_TAR_BZIP2 is not set
  1447. # BR2_TARGET_ROOTFS_TAR_LZMA is not set
  1448. BR2_TARGET_ROOTFS_TAR_OPTIONS=""
  1449. # BR2_TARGET_ROOTFS_UBIFS is not set
  1450.  
  1451. #
  1452. # Bootloaders
  1453. #
  1454. # BR2_TARGET_BAREBOX is not set
  1455. # BR2_TARGET_MXS_BOOTLETS is not set
  1456. # BR2_TARGET_UBOOT is not set
  1457.  
  1458. #
  1459. # Kernel
  1460. #
  1461. BR2_LINUX_KERNEL=y
  1462. # BR2_LINUX_KERNEL_3_8 is not set
  1463. # BR2_LINUX_KERNEL_SAME_AS_HEADERS is not set
  1464. # BR2_LINUX_KERNEL_CUSTOM_VERSION is not set
  1465. BR2_LINUX_KERNEL_CUSTOM_TARBALL=y
  1466. # BR2_LINUX_KERNEL_CUSTOM_GIT is not set
  1467. BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION="/home/chrisw/embedded/linux-3.4-ss4000e.tar"
  1468. BR2_LINUX_KERNEL_VERSION="custom"
  1469. BR2_LINUX_KERNEL_PATCH=""
  1470. BR2_LINUX_KERNEL_USE_DEFCONFIG=y
  1471. # BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG is not set
  1472. BR2_LINUX_KERNEL_DEFCONFIG="iop32x"
  1473. # BR2_LINUX_KERNEL_UIMAGE is not set
  1474. # BR2_LINUX_KERNEL_APPENDED_UIMAGE is not set
  1475. BR2_LINUX_KERNEL_ZIMAGE=y
  1476. # BR2_LINUX_KERNEL_APPENDED_ZIMAGE is not set
  1477. # BR2_LINUX_KERNEL_VMLINUX is not set
  1478. # BR2_LINUX_KERNEL_IMAGE_TARGET_CUSTOM is not set
  1479. # BR2_LINUX_KERNEL_DTS_SUPPORT is not set
  1480. # BR2_LINUX_KERNEL_INSTALL_TARGET is not set
  1481.  
  1482. #
  1483. # Linux Kernel Extensions
  1484. #
  1485. # BR2_LINUX_KERNEL_EXT_XENOMAI is not set
  1486. # BR2_LINUX_KERNEL_EXT_OCF_LINUX is not set
  1487. # BR2_LINUX_KERNEL_EXT_RTAI is not set
  1488.  
  1489. #
  1490. # Legacy config options
  1491. #
  1492. # BR2_PACKAGE_CUSTOMIZE is not set
  1493. # BR2_PACKAGE_XSERVER_xorg is not set
  1494. # BR2_PACKAGE_XSERVER_tinyx is not set
  1495. # BR2_PACKAGE_PTHREAD_STUBS is not set
  1496. # BR2_PACKAGE_GETTEXT_STATIC is not set
  1497. # BR2_PACKAGE_LIBINTL is not set
  1498. # BR2_PACKAGE_INPUT_TOOLS_EVTEST is not set
clone this paste RAW Paste Data